2

When I installed elementary OS I also created a SWAP partition.
I'm a front end developer so at any moment I have a lot of chrome tabs open, I have just 6 gigs of memory in my laptop(Its soldered so can't really upgrade). It seems that elementary OS is just removing tabs from memory instead of moving them to the swap. I assume this because whenever I run grep Swap /proc/meminfo it just gives output something like this .
sarthak@envy:~$ grep Swap /proc/meminfo SwapCached: 8 kB SwapTotal: 8056828 kB SwapFree: 8031228 kB


Is there anything I can do about this?
5
  • Have you changed 'swappiness' from the defaults? If you have, you can try setting it back. 60 is the default. If you haven't, you can try turning it up to like 80 to see if it will help you use the swap more. This is a temporary setting when done this way sudo sysctl vm.swappiness=80 - try that and if it makes a difference then I'll write up an answer about how to apply it permanently.
    – KGIII
    Dec 19 '20 at 18:22
  • Thanks, no I haven't tried it yet, I try it right now. Dec 19 '20 at 19:49
  • 1
    Just tried it, it still doesn't seem to be working, i opened about 30 tabs +1 a youtube vid, swap usage is about 6 mb but tabs habe been cleared from memory, can the kernel have a role in this? I've updated from the stock kernel if that helps. Dec 19 '20 at 20:10
  • It could indeed be the kernel you've chosen. It's the kernel that decides when memory gets paged and the likes. It's effectively the task scheduler that decides things like that.
    – KGIII
    Dec 19 '20 at 20:13
  • 1
    I'll booth with the default 5.4 kernel version to see if that makes a difference. Dec 19 '20 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.