0

Elementary OS 5.1.7 Hera | Ubuntu 18.04.4 LTS | Linux 5.4.0-54-generic | GTK 3.22.30

Just reinstalled elementary after a series of issues, got a few programs installed through flathub, but otherwise a standard install.

Bluetooth was working fine for a few hours, then cut out mid music(spotify). Reconnected through system setting by cycling on/off bluetooth and headset, worked for a while longer, then dropped again.

Restarted system, and bluetooth icon is missing from wingpanel. Functionality in system settings is gone, it stays on "discovering" with no devices appearing.

systemctl restart bluetooth as per: https://github.com/elementary/wingpanel/pull/187

Does nothing.

rfkill - returns that bluetooth is unblocked.

systemctl status bluetooth - returns active and running.

/etc/bluetooth/main.conf has AutoEnable=true as per: Bluetooth simply not working at all

bluetooth ctl

list - returns nothing at all.

show - returns "No default controller available."

Seems that the software module is running.

Does this mean that this is a hardware compatibility issue? Im using this mobo with its stock antenna: https://www.gigabyte.com/Motherboard/B550-VISION-D-rev-10/sp#sp It's a sick mobo btw ;)

Im new to Elementary OS and Linux in general(1 month), just built this comp and wanted to take the leap into FOSS, so my troubleshooting depth is limited without guidance.

Everything worked ok for a while, but it seems that the hardware isn't being detected. Im missing something, any help would be appreciated.

1
  • Having the same problem here. Did you find any solution?
    – David
    Feb 28 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.