2

I am trying to install version 5.1 of JabRef (ElementaryOS brings 3.8.2) in my system. Up to now I have tried two methods:

  1. Install the deb from jabref webpage. In this case, I can open jabref but it is unresponsive (menu options do not work).
  2. snap install jabref. In this case I get an exception an the program closes when I click in a menu.

Any idea on how to do it?

2
2

I finally got it working. In my case the solution was forcing JabRef to use GTK2 instead of GTK3. Here are the steps:

  1. Download and install the .deb with sudo dpkg -i jabref_5.1-1_amd64.deb
  2. Fix dependencies if neccesary sudo apt-get install -f
  3. Locate the file JabRef.cfg. In my case it was in /opt/jabref/lib/app.
  4. Modify this file and add in the [Java Options] section -Djdk.gtk.version=2.

After that JabRef started working flawlessly.

Update:

After I updated to JabRef 5.2, the problem came back. After consulting with JabRef developers in github, I had to use this other workaround:

  1. Modify the file /opt/jabref/lib/runtime/bin/JabRef and add the -Djdk.gtk.version=2 modifier. Something like this: "$DIR/java" -p "$DIR/../app" -Djdk.gtk.version=2 -m org.jabref/org.jabref.gui.JabRefLauncher "$@"
  2. Modify the launcher so it points to this file. For that I installed menulibre (sudo apt-get install menulibre) and I modified JabRef entry to point to /opt/jabref/lib/runtime/bin/JabRef.
2
  • Nice! You can accept your own answer, sot that other can sfind this solution easier. – Vlad Dec 10 '20 at 17:03
  • seems I have to wait for two days for doing that. I will do it then! thx. – pglez82 Dec 10 '20 at 18:36
0

The best/easy way to install deb files is to use the Eddy app from the AppCenter https://appcenter.elementary.io/com.github.donadigo.eddy/

You can also use the Terminal:

sudo dpkg -i package_name.deb

1
  • Yes, I installed the deb using dpkg and jabref installs but when I open it, it is unresponsive. Anyone has this app installed in ElementaryOS? – pglez82 Dec 10 '20 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.