I just booted my elementary OS but no gui is loaded..i got promted into a terminal login and even if i log in i still get CLI ..tried startx but i get and error about initx? (if it helps i can post a picture of /var/logs/Xorg.0.log ) Yesterday I tried to install virtualbox using aptoide and nothig else..

I really have to re-install all the gui and drivers manually to make it working again or there is a quick "tip" to solve this?

I have elementary OS in dual boot with Windows 8 worked for about one week fine until now.

Edit: on the log i can sede Failing back to old probe method fglrx Fatal server errore: Caught signal 11 . server aborting

  • 1
    try this :sudo apt-get install --reinstall xorg
    – Ravan
    Commented Oct 20, 2015 at 9:11
  • I got same error: xinit giving up...xinit unable to connect to X server ...xinit server error
    – S4mick
    Commented Oct 20, 2015 at 9:16
  • please refer here and let me know the result
    – Ravan
    Commented Oct 20, 2015 at 9:20
  • Now it boots the GUI but it's stuck on the eos logo
    – S4mick
    Commented Oct 20, 2015 at 9:39
  • similar to this one here ?
    – Ravan
    Commented Oct 20, 2015 at 11:27

5 Answers 5


I had such an issue on my Freya HTPC installation. It was caused by some unsuccessful Nvidia driver installation. I fixed that by

sudo apt-get purge nvidia*

which reverted to standard driver.


I was running Elementary 5 in VirtualBox 6 (upgraded from 5) and the GUI stopped working.

Reinstalling elementary-desktop as suggested by @Jeroen using

sudo apt install --reinstall elementary-desktop

did not work for me, but this did:

sudo apt purge elementary-desktop
sudo apt autoremove
sudo apt install elementary-desktop

I'm sure the autoremove isn't necessary. I did it to be extra sure that everything was reinstalled properly.


This sounds really like an issue an friend of mine had. He thinks Virtualbox is causing it.

He fixed it by reinstalling the desktop and rebooting.

sudo apt-get install --reinstall elementary-desktop

You can get by an command line by pressing CRTL+ALT+F1


You need to use Ctrl+Alt+F1 to access (and log in via) the terminal. Then you can use any commmands can find in the help or know yourself to re-install packages). Similarly Ctrl+Alt+F7 will get you back in GUI mode (if one exists) although I usually reboot to test whether the changes have fixed the issue with sudo reboot or sudo shutdown now.

Then it is also possible to troubleshoot the issue or reboot into an earlier version (if it is a kernel issue). When I encountered similar issues, the information on Ubuntu forums such as the one below were sufficient to troubleshoot in Elemetntary OS (note that eOS Freya is based on Ubuntu Trusty 12.04).



Run the following commands:

sudo apt-get remove --purge libxfont1
sudo apt-get install libxfont1 xorg
sudo rm ~/.Xauthority

source here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.