1

When I open terminal through application menu (top left side menu) or from dock, then terminal opens with focus on it, over all other windows. When I try to open terminal through a shortcut, terminal opens behind focused window.

How to make terminal be on top of other windows on launch through a shorctcut?

  • shortcut means from dock? – Ravan Oct 19 '15 at 15:24
  • @Ravan shortcut means keyboard shortcuts, win + t – Константин Тукмаков Oct 19 '15 at 16:39
  • Are you sure about this behaviour ? because when I open browser over existing terminal , the win + t opens new terminal at background . – Ravan Oct 20 '15 at 9:09
  • I posted answer , please let me know your problem solved or not =) – Ravan Oct 20 '15 at 9:28
  • Any progress? Your problem solved? – Ravan Nov 26 '15 at 4:45
1
  1. Open terminal and run the command:

    sudo apt-get install compizconfig-settings-manager
    
  2. Open compizconfig-settings-manager , then

    General --> General Options --> Focus & Raise behaviour .

    Set Focus Prevention Level to off.

    Imgur

  • 1
    unfortunately I threw away elementary from my life, due to quite a lot of issues and not working software. But if somebody faces the same issue and accepts in comments, that your solution works - I will be glad to appreciate your try with upvote and choose it as a "right answer" – Константин Тукмаков Dec 9 '15 at 8:12
0

The answer appears to help. The newly created windows now always open in front of the other windows. The only minor annoyance is that they do not always have focus until clicked.

EDIT: I would post this as a comment but I don't have enough reputation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.