1

Recently decided to finally take the jump to Linux. Not being tech savvy I’ve tried my best but run into problems. I’ve searched the net high and low, nothing seems exactly like my problem and those which are similar I’m worried about losing data by giving commands I’ve no idea what they are doing.

So anyways problem is as follows. I’m using a Windows 7 Dell Inspiron N5110 laptop, I had an old 80GB partition on my HD for Flight Simulator which I wiped, renamed and allocated for Linux.

Put Elementary on to a USB drive, installed alongside windows to the 80GB partition. Install worked great, no problems; successfully installed. Said I needed to reboot to complete the install which I did but on restart the laptop started windows as normal.

I’ve looked in BIOS and Elementary/Ubuntu/Linux or anything else are not there to chose as a boot option. Just the standard diskette, USB, Network etc.

I ran the virtual version of elementary and used a program that was recommended, something partition. It clearly shows the 80GB partition, the files have installed to the destination, nothing looks broken or corrupted amongst the files.

It’s win 7 not 8 or beyond so I don’t even think it has a safe boot option but after searching the web it recommended this may be the problem but it isn’t because the option isn’t even there.

When I used the partition app in Elementary it did even tell me where the partition was mounted to so I’m convinced it has installed correctly.

At a total guess, from someone non tech-savvy; it’s almost as if Elementary has installed but the bootloader app hasn’t or the laptop doesn’t know I want it to boot Elementary OS from that specific partition.

Given the fact I can’t afford another HD to back everything up I am terrified of losing my data by doing the wrong thing or giving the wrong command. For example using a Linux code to mount the partition but not mounting the correct partition and wiping a partition I want to keep with a format. Or writing a wrong value and wiping everything.

Any help or direction would be greatly appreciated. Many Thanks.

  • I would try 'boot-repair'. You'll make the live USB (use Ubuntu as it's easier to add PPAs - it'll be okay even though it's not eOS) the same way you made the last one and then you'll follow these directions. However... You always risk data loss. It's pretty safe - but it is always a risk. It's a risk every time you turn on the computer. You can possibly find some online space to store your data, but you need a backup solution. – KGIII Nov 18 '20 at 22:42
  • You’re an absolute legend buddy thank you very much; your suggestion worked perfectly. I would note others had suggested the same thing on forums online but it got slated as bad advice because boot-repair isn’t available on Eos and many say it’s outdated and doesn’t have modern necessary features. Therefore I was sceptical of your advice but obviously you’re the professional and I’m not. Followed it to the T and it worked perfectly, using a live Ubuntu let me install boot-repair and it sorted the problem. Seemed to be a ‘hide bios menu’ option somewhere with an incorrect value. Thanks again – Slayer2029 Nov 19 '20 at 11:38
  • How do I allocate you with a green tick as the person who sorted the problem? – Slayer2029 Nov 19 '20 at 11:39
  • There you go. It's up as a full answer. I'm not a professional. I'm just a volunteer. Your happiness and working system is my reward. – KGIII Nov 19 '20 at 16:58
  • Also, I'd like to point you to this site. It is one of many sites, but it's the first one that was in my search results. I don't have any preferences for it, it was just the one I chose. If you're selective about what you backup, and you use encryption, you can take advantage of free online cloud storage. You need a backup plan. Disks go bad. Mistakes happen. Have a working, tested backup plan. It's essential for quality computing. – KGIII Nov 19 '20 at 18:12
0

For whatever reason, GRUB isn't working properly. I don't know why. I wasn't there when it was installed. So, we're going to fix it.

First, adding PPAs to eOS is a pain. It's possible, but let's just skip that step for the sake of simplicity. So we'll go ahead and download Ubuntu.

Once you've done that, you need to write the ISO to disk. You can write it to USB or DVD. If you're going to use USB, I recommend Balena Etcher.

Now, you'll need to boot the live instance of Ubuntu. As you've already installed eOS, you should know how to do this.

Once you're into the live instance, it's time to install the boot-repair PPA. Open your terminal with CTRL + ALT + T and:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt update

You probably don't need to update, it should do that automatically. If it doesn't, then do so and then run:

sudo apt install boot-repair

Let that install and then start it from that same terminal window:

boot-repair

Just go ahead and click the recommended repair and it's almost certainly going to fix this problem. If you have a more complicated problem, or if it doesn't work, then create a summary and share the link when you're asking a new question on this site or on other sites.

As always, backup any important data. And, you don't have to use Ubuntu. You can use any distro that enables you to install boot-repair. We're only using Ubuntu for the sake of expediency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.