2

Unable to update (from AppCenter) "xdg-desktop-portal desktop integration portal for Flatpak and Snap Version: 1.7.2-flatpak1~bionic"

The words contained within quotes above comprise the description listed under Operating System Updates.

As a workaround that prevents the update from appearing in AppCenter, I disabled these deb and deb-src repositories: ppa.launchpad.net/alexlarsson/flatpak/ubuntu/

3
  • > I disabled these deb and deb-src repositories: ppa.launchpad.net/alexlarsson/flatpak/ubuntu/ How? I’m having the same issue with the constantly-reappearing update and would like to do the same
    – Brandon
    Nov 22 '20 at 21:27
  • Brandon, I have Synaptic Package Manager installed. Using it, disabling specific repositories is easy: Go to Settings > Repositories from within the package manager's user interface.
    – Dan Mesmer
    Nov 24 '20 at 12:07
  • see also: github.com/flatpak/xdg-desktop-portal/issues/547
    – Friso
    Nov 24 '20 at 15:32
3

Remove the http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu ppa.

You might've added it from various guides around the internet when flatpak was released, that's how I got it. It's no longer needed as, since 5.1, elementary supports flatpak out of the box.

Source: https://github.com/elementary/os-patches/issues/145

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.