0

I have a DELL OptiPLex 7050.

I want to try ElementaryOS on it. It has Ubuntu (by default). I created the USB stick with ElementaryOS and also checked md5sum. No error found.

Secure mode is OFF on BIOS. When I boot into the USB, It shows elementary OS logo, and the message that it would boot on seconds. After that, instead booting ElementaryOS, it calls the DELL's Recovery Partition located on HD.

My HD has 4 partitions (in this order):
  1. EFI (839Mb) - /dev/sda1
  2. OS (DELL Recovery, 5.4Gb) - /dev/sda2
  3. UBUNTU (the real OS Partition) - /dev/sda3
  4. SWAP (34Gb) - /dev/sda4

What may be wrong fot it to boot always on the 2nd partition ??? I've tried a lot of modifications from BIOS but nothing worked. It always boot on Recovery Partition.

O.S.: I generated on the same USB disk a Ubuntu installation and it works perfectly. I could boot into it and use as Live USB disk.

Thanks !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.