When I start AppCenter, it runs for a few seconds and then crashes. I tried reinstalling AppCenter as suggested in this answer, but that didn't fix the problem.

Initially, AppCenter started without crashing, but it would fail to install some updates. I updated by doing:

apt-get update
apt-get upgrade
apt-get --with-new-pkgs upgrade
apt-get autoremove

Now my packages are up to date, but AppCenter crashes at startup.

When I run io.elementary.appcenter from the Terminal, I see these logs:

(process:7122): dconf-WARNING **: 11:30:43.965: Unable to open /home/ryan/.local/share/flatpak/exports/share/dconf/profile/user: Permission denied

** (io.elementary.appcenter:7122): CRITICAL **: 11:30:44.060: ComponentValidator.vala:37: Using .blacklist files is deprecated and will be removed in next version, please use .hiddenapps instead

(process:7130): dconf-WARNING **: 11:30:44.346: Unable to open /home/ryan/.local/share/flatpak/exports/share/dconf/profile/user: Permission denied

** (io.elementary.appcenter:7122): CRITICAL **: 11:30:44.353: FlatpakBackend.vala:186: Unable to get flatpak user installation : While opening repository /home/ryan/.local/share/flatpak/repo: /home/ryan/.local/share/flatpak/repo: opendir(/home/ryan/.local/share/flatpak/repo): Permission denied

** (io.elementary.appcenter:7122): WARNING **: 11:30:44.354: FlatpakBackend.vala:123: Couldn't create user Installation File Monitor due to no installation
Segmentation fault

Any thoughts on what might be happening or how I could fix the problem? Thanks!

1 Answer 1


It looks like the file permissions on the flatpak folder in your home directory (or possibly your home directory as a whole) are broken. Have you possibly ran a GUI program with sudo or ran some script that could have caused this?

I'd start by resetting the ownership of the flatpak directory. To do this:


sudo chown -R ryan:ryan /home/ryan/.local/share/flatpak

(Obviously if anyone else is reading this in the future, you'll need to substitute ryan for your username)

This will ensure that the flatpak folder and all of the files/folders within it are "owned" by your user. It's possible that the root account has taken ownership of them.

Then try running AppCenter from the terminal again and see if any of the messages are different.

If it still doesn't work you can try running:

flatpak repair --user

(Again trying to restart AppCenter from the terminal afterwards)

If it still doesn't work and you don't care about any flatpak applications you have installed (and potentially their settings), then you can remove the flatpak folder with:

sudo rm -r /home/ryan/.local/share/flatpak

It should get re-created with the correct permissions the next time you install a flatpak application.

However, if none of this fixes the issue, you potentially have bigger issues with permissions on files and folders as a whole in your home directory.

  • Changing permissions did the trick - thank you so much! (I also ran flatpak repair for good measure.) I haven't run a graphical program with sudo, but I did apply a whole year's worth of upgrades when I ran apt-get upgrade. Maybe that broke the permissions somehow? Anyway, thanks again for your help! Commented Nov 10, 2020 at 22:03
  • Here's the dynamic alternative: sudo chown -R $USER:$USER $HOME/.local/share/flatpak
    – Qumber
    Commented Mar 27, 2021 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.