Is there a simple, non-system-breaking way to install Compiz on elementary OS? I replaced Pantheon with the gnome-terminal so a lot of the tutorials I found don't appear to apply.

When I installed Compiz on other computers, I simply did

sudo apt-get install compizconfig-settings-manager
sudo apt-get update

and it worked fine. However, they were using the Unity DE. Will it work with whatever elementary OS is using (GNOME I think, not sure though)? It hasn't worked on other GNOME-using distros I have used.

My computer is brand-new and I spent a lot of time getting elementary OS to play nice with Windows 10, so I am a little nervous about just flat-out experimentation.

My operating system is Freya.


2 Answers 2


The desktop environment used is Pantheon, not Gnome.

And since elementary OS uses Gala (which is based on the Gnome 3 window manager Mutter) - not Compiz - as it's window manager, you can't use the Compiz Config manager: One could say, it's the core of elementary OS.

  • 1
    thanks! this is what I was afraid of. I am glad I checked here first!! :D Commented Oct 18, 2015 at 18:33

Just figured that I should update this question - it took a while to sort out all the details, but I got compiz working very nicely on Loki.

Here is my system:

         eeeeeeeeeeeeeeeee           OS: elementary OS 0.4.1 loki
      eeeeeeeeeeeeeeeeeeeeeee        Kernel: x86_64 Linux 4.13.0-26-generic
    eeeee  eeeeeeeeeeee   eeeee      Uptime: 1h 2m
  eeee   eeeee       eee     eeee    Packages: 2167
 eeee   eeee          eee     eeee   Shell: bash 4.3.48
eee    eee            eee       eee  Resolution: 3840x1080
eee   eee            eee        eee  WM: Compiz
ee    eee           eeee       eeee  WM Theme: elementary
ee    eee         eeeee      eeeeee  CPU: Intel Core i7-6700K CPU @ 4.2GHz
ee    eee       eeeee      eeeee ee  GPU: GeForce GTX 1050 Ti
eee   eeee   eeeeee      eeeee  eee  RAM: 1968MiB / 32128MiB
eee    eeeeeeeeee     eeeeee    eee 
 eeeeeeeeeeeeeeeeeeeeeeee    eeeee  
  eeeeeeee eeeeeeeeeeee      eeee   
    eeeee                 eeeee     
      eeeeeee         eeeeeee       

It was fairly straightforward for the most part.. but there were a couple of finicky things.

  1. Install compizconfig settings manager AND compiz fusion icon from the appcenter.
    • Compiz fusion icon is deprecated and doesn't do what it's supposed to do, but it does something (didn't take the time to figure out what) that makes everything work correctly. No idea why this is the case - maybe someone else can shed some light on it
  2. Use killall wingpanel; sleep .3; nohup wingpanel & sleep .3; nohup wingpanel --toggle-indicator app-launcher as a command to get to elementary's app launcher
    • Getting this launcher to work was quite tricky.
    • It has to be restarted every time it is launched from the terminal (in compiz, not in gala). It's pretty buggy but eventually I figured out a workaround
    • You may need to change the sleep times on your machine. Make sure that wingpanel has time to fully draw itself before trying to toggle the app-launcher
  3. The notification-daemon must be manually started. This is probably easiest to do with an alias when you first start compiz.

Put this in your .bashrc to fix the notification-daemon (you will need to leave the terminal running - or maybe nohup it):

alias co='nohup compiz --replace & sleep 2; /usr/lib/notification-daemon/notification-daemon;

And to get back to gala:

alias ga='nohup gala --replace &'

Now you can use 'co' to switch to compiz, and 'ga' to get back to gala - let me know if you would like my compizconfig file!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.