1

Does normal GRUB behaviour match my description below?

My original description follows; I edited my question to enable a yes/no answer. If others feel my GRUB is behaving as expected, I will focus on hardware issues and assume Elementary OS has nothing to do with my boot problem, and consider this answered.

I want my laptop to boot reliably. Boot fails if I leave it powered down for about 3 days, otherwise well-behaved. I hope advice here can help me understand what to investigate.

  • Dell Latitude D830
  • 4GB RAM
  • boot 500GB SATA SSD
  • Elementary OS 5.1.7 Hera
  • original Win7 HDD no problems
  • swapped HDD with SSD and Elementary Juno after coffee tragedy
  • no change fresh PRAM battery

After lengthy power-down periods, boot goes to GRUB. Workaround by selecting <Advanced options for elementary/elementary, with linux 4.15.0-122-generic (recovery mode)>. This option fails automatic checks and requests to run fsck manually. I run fsck manually on the only drive I know, <fsck /dev/sda1>—"all" switch doesn't find it—then reboot behaves properly and waits for input at the Elementary OS graphical login prompt. I never experience odd behaviour while in use. I've tried "Boot Repair" application, but after reporting repairs it lacks long-term effect.

2 anomalies:

  • sometimes I reboot and need to repeat fsck again, but I always win in the end
  • sometimes I'll make it as far as using the Elementary graphic interface, then AppCentre updates choke, black screen reboot, then GRUB reboot. Never happens elsewhere, only occasionally during AppCentre updates on boot.

Is the Elementary/Linux side of things behaving as expected?

8
  • Could you check BIOS which mode is your drive is set? – user.dz Oct 30 '20 at 23:15
  • BIOS A17 reports Primary Hard Drive = 480 GB HDD, SATA Operation set to ATA factory default, with AHCI alternative – SkyHook Oct 30 '20 at 23:43
  • I was suspecting you may have SoftRAID active, which makes similar behavior for some Dell laptops. Like here askubuntu.com/questions/696929/corrupt-backupt-gpt-table. – user.dz Oct 31 '20 at 0:26
  • ATA/AHCI should be fine, Many saying for SSD would be set AHCI, but I'm not sure if it will boot without re-installing. – user.dz Oct 31 '20 at 0:32
  • Power in but powered down 4 days - no change. A deception; same GRUB solution on boot dropped me at a screen I've never seen before, some kind of 8-bit style safe menu after FSCK was finished, with the option to continue to a graphic interface boot. New, but I think unrelated. Next, going to try sleeping under power for a few days. – SkyHook Nov 4 '20 at 19:40
0

Thanks for any advice, but I will close this as it appears the process is too complex for online conversations, too much detail required. I continue to use the laptop in question, letting automatic things happen automatically.

Anything further would probably require a deep understanding and dissection of every error message and log. My particular boot problem remains unchanged, but if I use this device daily it boots and logs in normally on first try. The workarounds continue without error as long as I reboot when it gets stuck, as if every dependent step is happy with the previous boot's automatic glitch repair. The most I've had are three reboots after not touching it for about two weeks, but now that I know it eventually works, I don't reach for the command line and just let it autopilot. I'm afraid that hardware is failing, in the long run, but diagnostic tools report all is fine.

1
  • Typically my problems never appeared if I booted daily, but today I found myself in a fsck file system conniption that took far too long to fix with my limited experience. I thought I had left this question open but that's fine as is, just adding this footnote that I've perforrmed the following with hope I never have to think about this again. Wish me luck: 'sudo nano /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT="quiet splash fsck.mode=force fsck.repair=yes" Ctrl+O, Enter, Ctrl+X sudo update-grub' – SkyHook May 1 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.