0

I need urgent help.

There was a bug (I think) on my elementary os. When i tried to restar it didn't recognize any operating system. I tried to reinstall elementary from my flash drive (as i did before) and it opens on the “try” mode but cannot install it. The message is: “No root file system is defined. Please correct this from the partition menu”. I added a new partition table, but the message was the same.

Background story: I installed elementary os on my notebook about 6 months ago. I save all my documents and works in an external drive. This past week I used my external drive on my friend’s computer (windows). When I came back home and tried to use my notebook (I use linux only) this happened (i don't know if it is related).

I only know the basics of linux. I need help “for dummies”. And im fucked because i have to finish an article for tomorrow! So please!!! Does anybody can help me?

The error was something like: [5828.052079] EXT4-fs error (device sda2) ext4-find:entry....

And some other things I could not capture

0

I fixed it!

First, I tried to reinstall elementary os from my USB stick - didn't work. The USB stick stopped working too.

Then I download OpenSuse in another USB stick. It worked on trial mode but it didn't find any directory on my computer. Therefore, it did not install anything on my computer.

Then I tried to install Manjaro. It didn't work, but a new message started to show on my screen about a bug in BIOS and initramfs. (before there was a message about no directory found). This was the turning point for me to fix it. Unfortunately, I don't know how it happened.

After, I followed this: https://www.youtube.com/watch?v=xf

Basically, you need to type: fsck /dev/sda1

It didn't work with sda1, so it tried with sda2. It worked!!

I followed the rest of the video (just type yes for everything). Then, type reboot. Then select the option *elementary, and that was it. My Notebook started to work again as it was before. Elementary was working as if anything has happened. I did not lose any of my packages.

I don't know what or how it happened but it worked. Above is exactly what I did. Probably most of it has nothing to do with the solution.

One more thing. The problem started after I tried to updated my elementary os. I did not try to update again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.