I spend all day trying to fix the problem but it was impossible. I updated my OS from update manager. I ran a game on steam and the pc has got freeze and then, I rebooted whit button.

When I try to login in login screen, appear one second the desktop, then back to login screen.

I reinstalled the headers, I checked the Xauthority and several other things but anything worked.

I need help!!

EDIT: my OS is Elementary OS Freya. I already tried:



  • sudo apt-get install --reinstall plank
  • sudo apt-get install --reinstall elementary-tweaks
  • Installed last graphics drivers from here


3 Answers 3


Did you try reinstalling Pantheon Desktop?

sudo apt-get install --reinstall elementary-desktop

Or reinstalling pantheon-greeter (you have tried to reinstall lightdm, but it's called pantheon-greeter)

sudo apt-get install --reinstall pantheon-greeter
  • I have tried right now but it doesn't work.
    – Mrquestion
    Commented Oct 16, 2015 at 19:48

I added an user and I could join in. Removed elementary-tweaks and numix-icon then I could join again with my user...

I installed again elementary tweaks and it works.

I hope this works for anyone.


I encountered with the same issue. I unfortunately ran earlier that that the

sudo chmod 777 -R .

command in my root directory, which changed all the permission on my computer, included my account. My account permission also change, therefore I was not allowed to log in into my account. Solution: When I ran the command again it solved the problem,I could log in into my account, but it's highly recommended to reinstall the compute for security reasons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.