0

This is my first attempt to experiment with some form of Linux.

I created a boot USB for Elementary OS 5.1.6 Hera using Rufus. The USB stick is a 256 gb Corsair Voyager. I booted from it, saw a bunch of errors related IRQ settings stream by, and then the screen went to black and stayed there.

My PC is a recent build that functions fine with Windows 10. Ryzen 3700X, Gigabyte B550 Vision D, 64 gb RAM, older GTX 630 GPU (it was laying around), Corsair Force MP600 NVME 1 tb SSD.

***** 09/18/2020

So it seems the problem has "gone away"...

@KGIII Have to admit that I don't know how/where to use "noacpi"... but maybe I don't need to.

I decided to create another USB stick; used a different stick and used Etcher for Windows, but the same ISO file. Rebooted the PC, hit F12 to get the boot menu, and selected the USB stick. Still got the IRQ errors:

0.320289] do_IRQ: 1.55 No irq for vector

This repeats for 2.55, 3.55, 4.55, 5.55, 6.55, 7.55, 8.55, 9.55, and 10.55.

Then the Elementary logo appeared, pulsed a few times, and then I got the try/install screen. I selected "try" and started checking things out.

The new USB stick is a 32 gb USB 2 model. The first one was a 256 gb USB 3 model. Would that make a difference? I tried both in the same front-panel USB 3 port.

  • Did you validate/verify the downloaded ISO? Also, I've seen a number of complaints with regards to Rufus lately. Maybe try again with Balena Etcher. IIRC, Rufus was defaulting to NTFS format for the disk and that's a poor choice. FAT32 is the correct choice. However, Balena Etcher will deal with all that for you and it's pretty straightforward. – KGIII Sep 16 at 23:45
  • I did; the hash matched. I tried to create the USB on my Mac with Etcher, but it kept failing. Then I switched to the PC, and Rufus worked. The stick is formatted as FAT32. – upRyzen Sep 17 at 0:40
  • When you say Rufus worked, does that mean you were able to install? – KGIII Sep 17 at 1:50
  • Rufus created the USB stick, and I was able to use it to boot the PC. During the boot process, I saw a stream of error messages that said something about IRQ. After they went off the screen, it stayed black. The PC was still powered on, but nothing else came up on the screen. I concluded that the boot process had not completed for some reason, but I'm really just guessing. – upRyzen Sep 17 at 10:19
  • If you get a minute, let us know what the IRQ errors were. But, you can try adding noacpi to your boot parameters. Actually, I just found a fairly clear answer that should help you get booted. Look here. – KGIII Sep 17 at 12:58
0

noacpi must be added in /etc/default/grub then grub must be rebuilt.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.