0

I installed Elementary OS alongside Windows 10 on MSI GF-63, had no difficulty getting things done but was stuck at the error screen shown below after I restarted the pc and I couldn't boot to elementary os. I went through all the forums related to this, none of them helped. I had ubuntu installed before and had the same issue but adding some parameters to the grub solved it, but didn't work now. I'd appreciate some help enter image description here

[EDIT] I tried booting with pci=noaer, pci=nomsi, & pcie_aspm=off but they all got me stuck at a screen with no errors showing

Fails to boot after adding the parameters

3
  • You could take a look here. I suspect the highest voted resolution will work in your case. – KGIII Sep 12 '20 at 23:18
  • That fact that all of those errors are "Corrected" makes me think that they're not actually an issue. This is more likely a graphics driver thing. Have you tried booting with the nomodeset kernel/grub parameter? – David Hewitt Sep 14 '20 at 8:36
  • I installed Elementary again (Added nomodeset but graphics worked perfectly after boot without installing) but left the partitioning for the system ("install alongside windows" option), and it worked perfectly (I still get the error screen but it blinks and it boots normally) It's probably a partitioning problem as I was partitioning on SSD and HDD but the system partitioned only on SSD (I moved the /home later to HDD), so most probably I misplaced some directories. I also had to configure the grub in the Shim uefi key management and everything went good. Thanks guys. – Ohgodwhy Sep 15 '20 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.