0

I am using an AMD rx570. I was using Ellesmere driver, but I tried updating it. Now when I reboot my computer all I see is a black screen (don't even see elementary startup logo).

I am able to access tty so I ran some commands:

I ran the command lspci and see that I'm using Ellesmere with kernel driver amdgpu.

I have also tried using init 5 but I get an error: v412loopback: failed video_register_device

Is there a way I can reset my driver?

Any help would be appreciated

Edit: Doesn't appear to be a gpu driver issue, I swapped out the gpu and still got the same issue. What other issue could prevent me from displaying the gui?

0

Try running on nomodeset, then if it successfully boots, revert your changes.

refer here for adding nomodeset manually when booting. Good luck!

(eOS is based on Ubuntu, so there will be no problems using that solution for eOS. Just make sure you follow correctly. And ignore it saying it's for Intel.)

1
  • Thanks! It appears to have disabled my gpu (I see the tty terminal is in lower quality). But I still can't get to the gui or login screen – Samuel Sep 7 '20 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.