0

Can you read this?

enter image description here

I can't. It hurts my eyeballs. I have a default system with default settings in an otherwise gorgeous oasis of visual goodness.

I just want to type the subdirectory name and run whatever "dir /s" is in linux. But I can't read the folder names.

I asked the internet. They had me mucking around with I don't even know what I probably sparked a small war in Uganda but it changed exactly zero when I launched terminal.

All the threads in here are like "jump over a 12 ft fence with green underware on and don't forget your purple hat and heart-printed socks".

I'm like "dude, there is no reason this should be anyone's default under any blue sky, starry night, or torrential rain on this lovely planet of ours".

please please please

there are daily updates to this system

please fix this nightmare default in one of them

I'm begging you, please

0

I have yet to try this, but if one installs 'elementary tweaks' from the CLI, then navigate to 'settings -> Tweaks -> Terminal', one should be able to select a colour theme.

EDIT: I tried out 'elementary tweaks'. Firstly, one is required to install a repository in order to access a Personal Package Archive (PPA), from which, to install 'elementary-tweaks'. Taking these first steps is at one's own discretion; the software is not part of Ubuntu's official distribution. Taking those steps, one will find the installation in 'System Settings -> Personal -> tweaks'. Clicking on 'Terminal' in the sidebar reveals options available to modify the Terminal, one of which is to change the background colour.

An alternative is Gogh, found at http://mayccoll.github.io/Gogh/ (note the hypertext protocol is not current, i.e., secure). However, it provides many colour themes to choose from and is simple to implement.

The issue you are experiencing, where there is a block of Green and text within it being difficult to read, cannot be changed to any great extent; through careful choice of theme, you should find one that has good contrast and readability.

0
0

You might want to look into Darcula:

https://draculatheme.com/

Here is an example of how it looks in Gnome Terminal: https://draculatheme.com/gnome-terminal/

0

It looks like you're not the only one according to issue #39 on Terminal's GitHub repository.

You can set the color palette for the terminal directly through gsettings on the command-line or the dconf Editor application. Your looking for the palette key found under the schema io.elementary.terminal.settings in particular.

The default setting is '#073642:#dc322f:#859900:#b58900:#268bd2:#ec0048:#2aa198:#94a3a5:#586e75:#cb4b16:#859900:#b58900:#268bd2:#d33682:#2aa198:#6c71c4'. To fix your particular issue, you might want to change the first occurrence of the #859900 in the list of colors to something like say a light gray, #a7a79f, as shown here:

$ gsettings set io.elementary.terminal.settings palette \
  '#073642:#dc322f:#a7a79f:#b58900:#268bd2:#ec0048:#2aa198:#94a3a5:#586e75:#cb4b16:#859900:#b58900:#268bd2:#d33682:#2aa198:#6c71c4'

To have this issue fixed in the future, please provide feedback to the elementary team through About -> Report Problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.