2

My Problem

When I start up Elementary, the audio through the computer speakers work as expected.

When I plug headphones into the audio jack, the audio doesn't come through the headphones.

Sometimes after disconnecting the headphones, the regular speaker audio will then stop working too until I restart the machine.

Having trouble connecting Bluetooth headset, my guess is Bluetooth is a separate issue for another thread (unless someone thinks it's all connected).

My Setup

Dual boot - Elementary OS Hera and MacOS Catalina (27-inch 2015 iMac)

What I've Done

  • This is the link for my ALSA information script http://alsa-project.org/db/?f=69fa3ea87565183bd98482333768713e81f66f17

  • I've run sudo apt update and sudo apt upgrade.

  • I've checked the audio settings and they seem to be fine. When I plug the headphones in they show up as the Sound Output device.

  • In opening alsamixer, I've made sure the headphone option is unmuted and volumes are raised. Same for gnome-alsamixer.

  • Forced AlsaMixer to reload

  • When I open pavucontrol, I can see the volume levels moving and receive no sound. I've tried multiple headphones.

  • Also in pavucontrol with the headphones plugged in, I've tried changing the output devices to Speakers (unavailable) and Headphones (plugged in).

  • Removed and reinstalled AlsaMixer and PulseAudio

  • Fast dispatcher is set to Run = no

I'm by no means a developer and have gotten this far in the installation through trial and error and lots of searching, so if more detail or information is needed, please let me know.

Any thoughts to resolve would be greatly appreciated.

3
  • 1
    Try this: open system settings>sound and plug your headphones. Then click over the headphones on the output tab. Do they work now?. How many jacks does your computer have? It can have one combo jack for mic+audio (like a smartphone) or 2 individual jacks (one for mic and the other for audio). Combo jacks have compatibility issues sometimes so it may be harder to solve. – Maccer Aug 26 '20 at 5:21
  • Did that and same result. The audio plays through the speakers with no headphones. I attach the headphones and can see the audio playing (in pavucontrol), but no sound through the headphones. It is a combo jack. – Calvin Hicks Aug 26 '20 at 13:41
  • ¿Do you have new info about this issue? – chronometreur Oct 2 '20 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.