0

Lately I installed eOS 5.1 Hera on my good old Asus X52JC (BIOS,no UEFI) next to Win10. Almost completely successfully, except an issue with GRUB I cannot get solved myself so far.

What works:

  • Boots into GRUB
  • When selecting eOS, eOS boots perfectly
  • When getting into BIOS and selecting "Boot Ubuntu" eOS boots perfectly
  • When getting into BIOS and selecting "Boot Windows Boot Manager" Win10 boots perfectly

However what does not work:

When selecting Windows in GRUB (yes it IS correctly mentioned in GRUB list), it just gets a black screen and gets back into GRUB menu.

Tried GRUB Repair app in eOS, to no avail (error message). It does seem a GRUB issue to me, as Win10 does boot when I select it in the BIOS.

What am I overlooking?

0

Found something on Ubuntuforum that helped me. Apparently my Grub2 boot did indeed contain an issue. Though it could be repaired without additional tools, just by two simple terminal commands as found at: https://askubuntu.com/questions/1149189/gnu-grub-2-02-boot-loop

1. Check the disk code
sudo fdisk -lu
In my case it resulted (predictably) in sda being the only physical disk.

Apparaat Begin Einde Sectoren Grootte Type
/dev/sda1 2048 206847 204800 100M EFI-systeem
/dev/sda2 206848 239615 32768 16M Microsoft gereserveerd
/dev/sda3 239616 778965559 778725944 371,3G Microsoft basisgegevens
/dev/sda4 778967040 780003327 1036288 506M Windows recovery-omgeving
/dev/sda5 780003328 937701375 157698048 75,2G Linux bestandssysteem

2. Apply a recheck (??) on grub:
sudo grub-install --recheck /dev/[hard disk]

For me it resulted in (translated from Dutch terminal, so exact wording may differ in UK/US terminal):

Installing for x86_64-efi-platform.
Installation finished. No errors were reported.

3. Update Grub
sudo update-grub

Sourcing file `/etc/default/grub'
Aanmaken van GRUB-configuratiebestand...
Linux-image gevonden: /boot/vmlinuz-5.4.0-42-generic
Initiële RAM-schijf-image gevonden: /boot/initrd.img-5.4.0-42-generic
Linux-image gevonden: /boot/vmlinuz-5.3.0-62-generic
Initiële RAM-schijf-image gevonden: /boot/initrd.img-5.3.0-62-generic
Windows Boot Manager gevonden op /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
voltooid

Now, I can boot both eOS and Win10 nicely from the GRUB menu. Lots easier for other family members too, as I do not want them to enter BIOS ;-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.