I tried to add the Japanese input method and so I installed fcitx to do so as I read it was the best. It didn't work so I tried on ibus and also uninstalled the fcitx software after that and I don't know how but I ended up with every layout remapped to some weird layout as shown in the pictures. The first picture is from an English keyboard layout and the second one is from a Portuguese keyboard layout.

English layout remapped? Portuguese layout remapped?

My setxkbmap -print -verbose 10 can be seen below, showing that the configuration is locked to some weird options.

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     br,us
variant:    ,
options:    grp:alt_shift_toggle,japan:hztg_escape,japan:nicola_f_bs,japan:kana_lock
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete+japan(kana_lock)
symbols:    pc+br+us:2+inet(evdev)+group(alt_shift_toggle)+jp(nicola_f_bs)+jp(hztg_escape)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete+japan(kana_lock)" };
    xkb_symbols   { include "pc+br+us:2+inet(evdev)+group(alt_shift_toggle)+jp(nicola_f_bs)+jp(hztg_escape)"    };
    xkb_geometry  { include "pc(pc105)" };

How can I go back to the default?

1 Answer 1


To simply reset the keyboard layout configurations you can use dconf. From the wiki:

dconf is a low-level configuration system and settings management tool. Its main purpose is to provide a back end to GSettings on platforms that don't already have configuration storage systems.

To reset the keyboard configuration you just reset the org/gnome/input-sources using the command dconf -reset /org/gnome/desktop/input-sources.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.