I am fairly technical and use PopOS as my daily driver, but my kid's school system is going full time remote, and I'm gonna be that dad who makes him use a linux laptop if he's gonna be stuck looking at it all day for 6 months or more. So I thought I'd buy a decent student notebook which seemed to be linux-compatible, and put eOS on it. Might be a perfect fit!

Computer is a Lenovo IdeaPad 5 15are05. Ryzen 5 4500U, with integrated AMD graphics.

However, I am having difficulty getting the OS installed.

  • I downloaded the USB ISO, flashed it to a drive, and verified everything with md5sum.
  • I made sure the machine BIOS was fully up to date
  • I disabled Secure Boot
  • I booted the machine, used F12 to get to the boot menu, and chose the USB drive.

I get the "Try or Install elementary OS" screen. Looks fine. I hit "enter" to boot, but it just goes to a black screen and sits.

I have tried a bunch of stuff. Not too familiar with GRUB (as PopOS doesn't use it) but I thought that I could get debug kernel boot output by hitting "e" at that screen and switching "quiet splash" to "debug nosplash", but no luck there. Still just a black screen.

Anything else to try? Is it possible that the kernel in the boot image is too old to wrangle this processor? Am I out of luck here?

Things I've tried (will expand list as I try more things):

  • Tried booting Arch Linux 2020.08.01 USB ISO without issue, which is based on the 5.7.11 kernel. Perhaps it's indeed the eOS kernel.
  • Tried "nomodeset" as a kernel arg, but still got a black screen.

Thanks for any pointers!

  • I've got exactly the same problem on my redmibook 16 with ryzen 4700u inside. I can boot others more recent linuxes like Fedora, ubuntu 20.04... but elementary 5 nope nope I tried nomodeset and another one like noacpi but to no avail I'm pretty desperate ! If anyone has a fix... and no beta iso of elem6 so far... I even tried respinning the elem iso with a 5.8 kernel... still the same result, i'm leaning toward a bug with system instead of graphical issue
    – Natille
    Commented Aug 8, 2020 at 12:37
  • I ended up giving up and going with Pop OS. I installed the Xanmod kernel post-install to get the recent AMD power saving changes. It's been solid.
    – Jonah
    Commented Aug 18, 2020 at 2:21
  • I tried the same . Mine is a Thinkpad e14 gen 2 ryzen 4500u. Luckily , I could install elementary os with latest iso . But there was no proper graphics driver support in 5.4 kernel.It boots and works . But there are graphical glitches and clunky animations. Then I tried to install mainline kernel to 5.10 . I couldn't boot with that kernel. Then I tried the kernel using Ubuntu Kernel Update Utility(UKUU) to 5.10. But it didnt boot either. So I'm now in Ubuntu waiting for elementary os 6 to come. I think unfortunately , Ubuntu 18.04 gets till only 5.4 kernel as of now I think for its life cycle. Commented Feb 26, 2021 at 14:13

3 Answers 3


You can try this: -On the GRUB screen press the "E" key on your keyboard, this will launch an editor.

-In the editor, use the arrow keys to locate the end of the line that starts with "linux /boot/vmlinuz***" (each bootloader may say something slightly different).

-Type "nomodeset" at the end of the line. You might end up with something like "quiet splash nomodeset" for that line. You can make sure is the end of the line by pressing the END key in the "linux /boot/vmlinuz***" line.

And that's it, if it works update or install your video card drivers which is more likely causing this issue.

  • Thanks for the suggestion! I did try that (see above). No joy - still a black screen after hitting ctrl-x to boot.
    – Jonah
    Commented Aug 8, 2020 at 0:05

burn a dvd. After several weeks of trying to boot with a USB and installing, I gave up. Then I was given a bunch of blank dvd's. I burned elementary to a dvd and it installed with no problem. I erased the computer and tried several times and it worked every time!


same issue on a HP Mini-210-1010 trying to use Elementary OS-6 live booted from USB thumb drive. gets all the way through and they hangs at "try Demo Mode" after to edit. not a black screen, just hangs. MX Linux, XUbuntu and Linux Mint all boot up for a live demo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.