1

I have just installed Elementary OS on my laptop, and everything including the WiFi is working. I can do

ping google.com

and it also works (shows correct IP). However, when I try to actually go to google.com it wouldn't load (loads forever). This is same for every request, including doing things like

sudo apt-get update

I can access my router's page though. What would be a reason for it to be happening?

(Acer Aspire One 32 bit)

  • Which browser did you use when you tried connecting to Google? Have you tried using some other browser? Do other internet-dependant applications (like Geary for example) work? Also, I can't figure out can you execute sudo apt-get update or can't because you said that the "same thing happens". Same thing as you got when pinging Google or the same thing you got when trying to open Google? – r3bl Oct 15 '15 at 1:34
  • @r3bl apt-get update will get stuck because it can't download anything. It's strange that later I switched to another WiFi hotspot (same router, different SSID) the internet suddenly worked. One thing to notice is that the original SSID I connected to is not in English (Unicode). It might be the problem. – Derek 朕會功夫 Oct 15 '15 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.