0

I have a USB dongle for Wifi, a TP-Link one, which is basically a realtek card (I believe). In the beginning it worked, now though Switchboard shows the oxymoron "Cable unplugged" on my wireless connection.

I've tried sudo ifconfig wlxe8de27078274 up and it works, but switchboard does not change its state, even after I restart the network-manager. I can also successfully search for Wifi connections using sudo iwlist wlxe8de27078274 scan | grep ESSID, of course only after I enable the card using ifconfig. To my surprise though, nmtui does not show my card.

I believe the problem must be somewhere in the initialization of the card's driver when the system boots.

I've tried installing the realtek dkms drivers, and bcmwl-kernel-source, but to no avail. enter image description here

0

Apparently sometimes the wifi is getting softblocked by network manager. The solution was unblocking it using nmcli r wifi on. I don't really know how this happened, but it's certainly a bug. I will probably report it to the network switchboard plugin github issues later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.