0

I installed EO yesterday and I've had a couples of bugs related to wifi.

First, Hera will recognize my Mercusys N150 Wireless USB Adapter(MW150US) but only when I unplug it and then plug it again. When I boot I wont be able to use wifi even trying:

sudo nmcli radio wifi on

Following other threads I tried these commands with these outputs:

    $ lshw -C network
WARNING: you should run this program as super-user.
  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 06
       serial: 70:85:c2:d9:9c:5f
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII
       resources: irq:22 ioport:e000(size=256) memory:91104000-91104fff memory:91100000-91103fff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@1:3
       logical name: wlx386b1c7e6240
       serial: 38:6b:1c:7e:62:40
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu ip=192.168.1.10 multicast=yes wireless=IEEE 802.11bgn
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

.

rfkill list all

Rfkill listed nothing.

I've been reading and it seems to be a Pantheon problem rather than kernel or drivers. Is there a script or something I can run at startup to solve this?

Second, the enable/disable botton of the system tray will block my wifi unless I do:

sudo nmcli radio wifi on

So my solution is to not touch it anymore. (Pretty bad one though) Is there a better fix to this?

Thx.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.