I just installed Hera. As you can see, there is no wifi in settings. as you can also see, the wifi icon seems to have been replaced by the "wired" symbol on the top bar. I cant turn on any of the options on that symbol

Please note that i have no access to the internet at all on the laptop. i do, however, have a pc that is connected to wifi. (the one im posting on) i also have a usb flash drive. (the one i used to transfer the screenshot files.)

OK, ive found the specs:

HP 14-DK0002DX

14″ Laptop (AMD A9 with Radeon R5, 4GB RAM, 128GB SSD)

enter image description here

I have wifi now via usb tethering on my phone!


2 Answers 2


OK, I've figured it out myself following these instructions: https://github.com/smlinux/rtl8723de/blob/current/README.md


Checking the issue with these two commands to find out what Wi-Fi adapter you are using and do you have any information about missing firmware.

sudo lspci
sudo update-initramfs -u

Getting Internet

We need a temporary internet connection to fix WiFi. Ways to connect :

Connect USB cable and use USB Tethering in your phone to connect your computer to the internet (through phone's cellular data/WiFi)Use wired ethernet cable for connecting to internet.


You should install the corresponding header of your kernel. Open terminal and type:

This as first:

sudo apt-get install linux-headers-`uname -r` 

Next, install the packages necessary for building :

This as second:

sudo apt-get install git build-essential dkms

Then type in terminal as third:


And then type this as fourth command in order, everything in one line.

git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git 

Type this as fifth command:

sudo dkms add rtlwifi_new 

Type this as sixth command:

sudo dkms install rtlwifi-new/0.6

Restart laptop.

If you will have issue with typing commands one by one, use this one-liner:

sudo apt-get install linux-headers-`uname -r` && sudo apt-get install git build-essential dkms && cd  && git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git && sudo dkms add rtlwifi_new  && sudo dkms install rtlwifi-new/0.6

And then restart laptop.

Other methods described here:


  • I tried this: git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git But it asks for a login and password. Commented Jul 17, 2020 at 17:20
  • sorry for the late comment, but the link appears to be broken. When i run the command, it asks for my login and password, and even when i answer it properly, it has an error and fails.
    – tim
    Commented Jul 19, 2020 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.