I'm running eOS 5.1.6 Hera on Dell XPS 13 (9300) as daily driver and am really enjoying it. That said, after a reboot today the system-wide fonts got completely broken and show as rectangles everywhere in system menus.

I tried a bunch of solutions previously suggested, including:

  • Reinstalling elementary-tweaks/elementary-desktop
  • Resetting the fonts
  • Changing settings of screenshot tool (since there used to be a bug related to it)

I also rebooted system multiple times after each of those attempts. I did not install any specific apps since prior to the issue, but might have updated apt. Just in case, I was using Inter fonts as system fonts and dark UI theme installed using elementary tweaks and the hack proposed here.

In addition, when I go to the elementary tweaks interface and try to change the fonts there, the tweaks fail and close immediately. I also noticed that the pre-installed Fonts app does not show any fonts, but the font-manager I installed myself shows the fonts (though the interface and menus fonts are still broken). Also, interestingly, when I login as guest the fonts show up properly, but the Pantheon desktop stops working when I try to use any system interface.

I would really appreciate any help with this issue, since I'm new to eOS and wanted to use it as a daily driver, but this issue makes it completely unusable.

UPDATE: Issue solved

I actually managed to resolve the issue myself by rebuilding the font cache by running sudo fc-cache -f -v in the terminal session. Still not sure exactly what caused the issue, but this restored all the fonts and now everything works properly.

  • Juno is not the latest version of Elementary OS. The latest is Hera.
    – Sysadmin
    Commented Jul 12, 2020 at 13:39
  • @Sysadmin , yes, you're totally right, I am running Hera. Corrected the title. Commented Jul 12, 2020 at 15:15
  • Nothing wrong with answering your own question, but it would be helpful to put the answer in the answer section.
    – Paul
    Commented Jul 14, 2020 at 22:05

7 Answers 7


You can try also to rebuild font cache by typing in terminal:

sudo fc-cache -f -v
  • Yes, this solved it for me. Thank you for all the proposed solutions! Commented Jul 12, 2020 at 19:31
  • I am glad. I provided other solutions. Maybe it will help others if they will have an issue with fonts. Please upvote this one solution with rebuilding font cache.
    – Sysadmin
    Commented Jul 12, 2020 at 19:34
  • I did, but I don't have enough reputation to make it publicly visible yet. Thanks again. Commented Jul 12, 2020 at 19:41

Access the terminal with Ctrl+Alt+F1 and type:

sudo apt install --reinstall elementary-desktop
sudo systemctl reboot
  • I tried this approach, the desktop app was reinstalled successfully and the fonts were reset to default values (confirmed by calling gsettings get). Still the issue persists and none of the system fonts work. Commented Jul 12, 2020 at 16:58
  • The question is, do you have important data on the system? I recommend to make a backup and then install the system from the scratch. I really have no idea what happened and why it behaves like you described.
    – Sysadmin
    Commented Jul 12, 2020 at 17:01
  • I can definitely reinstall from scratch, but I wanted to try and understand what caused the issue, given that it started out of blue and there is no guarantee it won't happen again after I spend hours reinstalling and setting up the apps. Commented Jul 12, 2020 at 18:00
  • Try perform and upgrade: sudo apt update && sudo apt upgrade -y && sudo apt dist-upgrade -y && sudo apt autoremove -y && sudo apt autoclean -y
    – Sysadmin
    Commented Jul 12, 2020 at 19:11

After reinstalling Elementary OS desktop open terminal and type:

gsettings reset org.gnome.desktop.interface font-name            

gsettings reset org.gnome.desktop.interface document-font-name 

gsettings reset org.gnome.desktop.interface monospace-font-name

gsettings reset org.gnome.desktop.wm.preferences titlebar-font 

gsettings reset org.gnome.nautilus.desktop font 

gsettings reset org.gnome.desktop.interface text-scaling-factor 

You can check this by type the command in terminal:

sudo tail /var/log/dpkg.log

and provide the results here.

Also command:

sudo journalctl -xb 

Will contain information.

Additionally you can check what you have installed by typing:

sudo tail -n 50 /var/log/apt/history.log

Also worth to check this:

sudo tail /var/log/fontconfig.log

Check this thread: ttps://elementaryos.stackexchange.com/questions/13499/elementary-os-system-fonts-haywire

Click the Application on the wingpanel (top left), type screenshot , run it, and switch the switcher Conceal text to disable it.

Screenshot app


You can also create additionally a new user in the system and check do fonts displaying correctly or not by logging to the new user account.


One more solution is to install BleachBit and run it as standard user not as a root.

How can I clean the system from unnecessary files?

Select options I highlighted on the screenshot.

BleachBit user settings

After that run BleachBit as root from Applications. If it will not run, open terminal and type

sudo bleachbit

And select as below on the image.

BleachBit as root

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.