3

For about a month now, I have been unable to use any USB devices of any kind. When I plug in one of my flash drives, which has an LED indicator, the indicator does not light up, meaning that there is not even power going through. Any advice on fixing this would be greatly appreciated.

Here is some information that may be relevant:

gabriel@Thoth:/var/log$ sudo lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

gabriel@Thoth:/var/log$ cat dmesg |grep -i usb
[    0.250072] ACPI: bus type USB registered
[    0.250095] usbcore: registered new interface driver usbfs
[    0.250105] usbcore: registered new interface driver hub
[    0.250130] usbcore: registered new device driver usb
[    1.141150] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.141378] ehci-pci 0000:00:1d.0: new USB bus registered, assigned bus number 1
[    1.155667] ehci-pci 0000:00:1d.0: USB 2.0 started, EHCI 1.00
[    1.155738] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.155743] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.155746] usb usb1: Product: EHCI Host Controller
[    1.155750] usb usb1: Manufacturer: Linux 3.13.0-65-generic ehci_hcd
[    1.155754] usb usb1: SerialNumber: 0000:00:1d.0
[    1.155959] hub 1-0:1.0: USB hub found
[    1.156184] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.156209] uhci_hcd: USB Universal Host Controller Interface driver
[    1.156428] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 2
[    1.156799] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[    1.156803] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.156807] usb usb2: Product: xHCI Host Controller
[    1.156811] usb usb2: Manufacturer: Linux 3.13.0-65-generic xhci_hcd
[    1.156814] usb usb2: SerialNumber: 0000:00:14.0
[    1.157006] hub 2-0:1.0: USB hub found
[    1.161050] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
[    1.161118] usb usb3: New USB device found, idVendor=1d6b, idProduct=0003
[    1.161122] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.161126] usb usb3: Product: xHCI Host Controller
[    1.161129] usb usb3: Manufacturer: Linux 3.13.0-65-generic xhci_hcd
[    1.161132] usb usb3: SerialNumber: 0000:00:14.0
[    1.161334] hub 3-0:1.0: USB hub found
[    1.479541] usb 1-1: new high-speed USB device number 2 using ehci-pci
[    1.611935] usb 1-1: New USB device found, idVendor=8087, idProduct=8000
[    1.611940] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    1.612192] hub 1-1:1.0: USB hub found
[    1.779462] usb 2-1: new high-speed USB device number 2 using xhci_hcd
[    1.832248] usb 2-1: New USB device found, idVendor=5986, idProduct=0535
[    1.832250] usb 2-1: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[    1.832252] usb 2-1: Product: Lenovo EasyCamera
[    1.832254] usb 2-1: Manufacturer: Generic
[    1.832255] usb 2-1: SerialNumber: 200901010001
[    2.003347] usb 2-5: new full-speed USB device number 3 using xhci_hcd
[    2.020509] usb 2-5: New USB device found, idVendor=0cf3, idProduct=3004
[    2.020512] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.187302] usb 2-6: new full-speed USB device number 4 using xhci_hcd
[    7.206345] usb 2-6: New USB device found, idVendor=048d, idProduct=8386
[    7.206351] usb 2-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    7.206354] usb 2-6: Product: ITE Device(8386)
[    7.206356] usb 2-6: Manufacturer: ITE Tech. Inc.
[    7.373403] usb 2-7: new full-speed USB device number 5 using xhci_hcd
[    7.398516] usb 2-7: New USB device found, idVendor=03eb, idProduct=8c1d
[    7.398520] usb 2-7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    7.398523] usb 2-7: Product: Atmel maXTouch Digitizer
[    7.398526] usb 2-7: Manufacturer: Atmel
[   11.716017] usbcore: registered new interface driver btusb
[   11.934039] usbcore: registered new interface driver usbhid
[   11.934045] usbhid: USB HID core driver
[   12.075722] usb 2-5: USB disconnect, device number 3
[   12.076636] usbcore: registered new interface driver ath3k
[   12.320124] hid-generic 0003:03EB:8C1D.0003: hiddev0,hidraw0: USB HID v1.11 Device [Atmel Atmel maXTouch Digitizer] on usb-0000:00:14.0-7/input1
[   12.336752] input: Atmel Atmel maXTouch Digitizer as /devices/pci0000:00/0000:00:14.0/usb2/2-7/2-7:1.0/input/input7
[   12.336999] hid-multitouch 0003:03EB:8C1D.0002: input,hidraw1: USB HID v1.11 Device [Atmel Atmel maXTouch Digitizer] on usb-0000:00:14.0-7/input0
[   12.353144] usb 2-5: new full-speed USB device number 6 using xhci_hcd
[   12.509464] input: Lenovo EasyCamera as /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0/input/input11
[   12.509872] usbcore: registered new interface driver uvcvideo
[   12.509877] USB Video Class driver (1.1.1)
  • Have you tried using USB ports on the same device using any other operating system? – r3bl Oct 14 '15 at 10:35
  • We need a little more information before we can help you. What does the command sudo lsusb return? – Jeroen Oct 14 '15 at 10:39
0

Thank you to everyone who tried to help. Eventually a friend and I figured it out. Because I installed elementary OS while it was still in beta, there were some problems with the update. Eventually (After thoroughly backing up) I manually installed the most recent kernel. That seems to have fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.