0

I have tried all the examples on this forum but still no avail.

I have nfs-common install and edited my /etc/fstab file with these lines to mount my two shares.

192.168.1.5:/data/Music /mnt/LIBATNETNAS/Music nfs user,noauto,rsize=8192,wsize=8192,timeo=14,intr 192.168.1.5:/data/Videos /mnt/LIBATNETNAS/Videos nfs user,noauto,rsize=8192,wsize=8192,timeo=14,intr 192.168.1.5:/data/Documents /mnt/LIBATNETNAS/Documents nfs user,noauto,rsize=8192,wsize=8192,timeo=14,intr

It just doesn't mount at startup, while mounting them individually works.

I can even use this command manually and it works.

sudo mount -t nfs 192.168.1.5:/data/Music /mnt/LIBATNETNAS/Music && sudo mount -t nfs 192.168.1.5:/data/Videos /mnt/LIBATNETNAS/Videos && sudo mount -t nfs 192.168.1.5:/data/Documents /mnt/LIBATNETNAS/Documents

It just doesn't work at startup on Elementary OS, all other distros work which is a bit frustrating.

I hope anyone can help.

Thanks!!!

0

Try this way. Delete those three entries from nfsdb file and add instead of them these three:

Music       -fstype=nfs4,rw,soft,intr   192.168.1.5:/data/Music 
Videos      -fstype=nfs4,rw,soft,intr   192.168.1.5:/data/Videos 
Documents   -fstype=nfs4,rw,soft,intr   192.168.1.5:/data/Documents

One below other, probably the first one is working and other two not, because they are not below. If nfs4 will not work, change it to nfs.

| improve this answer | |
  • Thank you!!! It sort of works, it works when I go to the folders using the command line the first time. It doesnt auto load. I have to go to the Music, Videos and Documents folder to sort of enable it. i just got used to the fstab way that it just works without doing anything – darellsison Jul 5 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.