1

enter image description here

I am using latest elementary OS. I have some updates in my laptop but when i hit update button it says Requires installation of untrusted packages. How can I solve?

  • please let me know my answer is useful or not...if solved please accept it as answer. – Ravan Oct 14 '15 at 13:21
  • does your problem solved ? – Ravan Oct 20 '15 at 13:39
  • yes! it is now solved. – Takshak Rajput Oct 30 '15 at 9:22
  • please acept my answer if it solved your problem :) – Ravan Oct 30 '15 at 10:28
6

Option 1:

To solve this install y-ppa-manager.To install open terminal and run:

sudo add-apt-repository ppa:webupd8team/y-ppa-manager
sudo apt-get update
sudo apt-get install y-ppa-manager

Now run y-ppa-manager from terminal.

When main y-ppa-manager window openend,click on Advanced

From the advaced list--> click on Try to import all missing GPG keys then click OK.

Option 2:

Open Software and Updates, change download from to : Main Server ,then try again.

Option 3:

Open terminal and run the following commands:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

Reference here and here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.