1

I am on elementary os 5.1 on MB Pro mid 2012. I believe that is 11,1. Everything worked great last night but turn on from normal shutdown and now missing keyboard, touchpad, wifi and Bluetooth and screen resolution is wrong.

I can connect USB mouse and keyboard. uname -r shows 5.3.0-1026-gke

Tried looking at log files in /VAR/ but print is small and nothing stands out just yet.

I am going to try to download another image to see if this is hardware or driver. I do not dual boot, so no grub to my knowledge.

I did some work with snaps yesterday to install wireguard. Any help would be appreciated

New contributor
Richard Behler is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • So, I can get a grub terminal with esc during boot. Looks like a software/driver issue. I'm hoping this helps, but I cannot get a bit USB until later this evening – Richard Behler Jun 29 at 20:55
0

Wireguard is available in kernel 5.6 or newer, so the question is did you compile kernel 5.6 or newer from the source code and additionally performed update-initramfs after that? And yes this command can show missing firmware which need to be installed. It seems you messed up your system because of wireguard. I am wondering which tutorial did you use to make wireguard work.

| improve this answer | |
  • Well, if wireguard is available in later kernels, it was not documented when I went to install. Additionally, I installed through snaps and world have expected that there install process would have notified me much like apt does. – Richard Behler Jul 1 at 7:33
  • It feels like a real stretch to think wireguard would somehow corrupt drivers for keyboard and touchpad. I can relate the wifi and Bluetooth, unless somehow the bus driver for all four is common. I can go find the link for how I arrived at installing snaps and wireguard if you feel that will help, but I'm back on mint xfce again and cannot provide any other help – Richard Behler Jul 1 at 7:39
  • That is fine. Eventually you can install additionally Elementary OS alongside with Mint. Depends on you. Hard to say actually what broken the system. Always you can use sudo journalctl -b to see errors from the current boot only. Ctrl+Alt+F1 to F6 switches to terminal if you are not able to login. – Sysadmin Jul 1 at 8:08
  • Thanks. I am not that familiar with journalctl at this time. I don't think I will be returning to Elementary as it was beautiful to look at, but felt confined in the applications capacity and using the Retina display was a bit of a challenge with some apps (steam particularly). Mint has better options for my use there. Nvidia just screws everything up in both OS FWIW. Backlight and resolution options horrible support. – Richard Behler 2 days ago
  • That is why Linus Torvalds said NVidia f..... you. He was exactly talking about the cooperation with them and that they do not support Linux well. The same is with the AMD, maybe less a little bit. However still Linux is not able to fully offer what Apple or Microsoft are. The whole problem is with the firmware (drivers). Usually Linux does not work out of the box like in case of Apple or Microsoft OS. And it requires knowledge to solve issues on your own on terminal level. Average user is not still a target I think. Mint or Ubuntu which are supported pretty well maybe give better experience. – Sysadmin 2 days ago

Your Answer

Richard Behler is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.