0

The Dell Precisions 7530 has a 8th Gen Core i7, 512GB SSD, Nvidia P2000 GPU, and 16GB of RAM.

After Installing Elementary OS 5.1.5 and getting it all setup, it works wonderfully when plugged into the AC adapter. From both a restart and a cold boot it will freeze right after the GRUB selection screen when it's on Battery. I've tried the previous Kernel, recovery mode, and neither of those changes make a difference. I added noacpi to the Grub boot options and that seems to fix the freezing issue, but now the Battery indicator is gone from the wingpanel.

I tried Ubuntu 20.04 and Pop!_OS to see if that would help, and same exact problem.

I tried disabling the Nvidia GPU and only using the Intel iGPU, same problem.

Verified all the BIOS/UEFI settings, and everything appears fine.

Finally, I re-installed Elementary OS BUT I didn't apply updates when installing, just drivers and 3rd party codecs. After that, it boots fine on Battery or AC, with or without Nvidia. I then used AppCenter to install updates one by one. I installed all available updates except the big "OS" update, and it was still booting fine. After rebooting I installed the big "OS" update and that's when it freezes after GRUB.

So other than not updating what are my options?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.