I'm unable to play music in the default music player. Every time I need to import files it shows a red dash as shown in screenshot.



I already have ubuntu-restricted-extras installed.

  • I was having the same problem. The only way I was able to listen to my music again was by installing a third-party audio player, audacious. I have not had that problem since. That is what I would recommend for you. Oct 13, 2015 at 21:20
  • could you provide some (detailed) info about how you imported the files? where are they located, do you have the 'copy files to Library' or 'keep Music folder organised' options on or off? Oct 14, 2015 at 9:22
  • 1.I imported files from gear symbol at top right corner.2.The files located in hard disk partition.3.All options are in ON state.
    – Ravan
    Oct 14, 2015 at 11:25
  • Cool, were the music files already in the music folder (before you imported them), and have they copied there if not? Oct 14, 2015 at 21:18
  • sorry-I misunderstand your second Q.Well,No the music files are in separate partition and I Import them by changing location in preferences...@TimothyGray
    – Ravan
    Oct 15, 2015 at 0:27

4 Answers 4


Probably a codec problem. I had the same on elementary live usb. During your installation, did you check the box "install proprietary software"? What is the extention of your music files? Does it works with a .ogg file?

You can install evrithing you might need by installing ubuntu-restricted-extras. Do it from the software center or run :

sudo apt-get install ubuntu-restricted-extras

If it still don't work learn about installing the codec for your format, or different ways to do that.

  • thanks for reply, I already installed codecs (ubuntu-restricted-extras), so its not the issue :)
    – Ravan
    Dec 18, 2015 at 2:49
  • Can you click on the red thing? If you leave the mouse above it a long time, does it says somehing? What? Have you tried with other extentions? if it works with an .ogg file I am shure this is a codec problem. Have you tried with vlc or Rythmbox? I think I can help you you need to answer those questions.@Ravan Dec 18, 2015 at 8:23
  • thanks, I can't produce error message now( I am outside). vlc working fine.
    – Ravan
    Dec 18, 2015 at 9:12
  • any other possible solutions?
    – Ravan
    Jan 3, 2016 at 2:27

I just had this same problem, and the way I solved it was simple.

I imported the files in the ~/Music folder from an external drive with an ntfs filesystem.

And the database that was created was still linking to the external drive.

To fix this was very easy. If you are comfortable with terminal use, do the following (or use the Files app to open HOME and show hidden files.)

First, close noise.

Then, in a terminal:

cd ~/.local/share/noise 
rm database_0_3_1.db

You can now exit the terminal, and start Noise again.

If all of the files are already in Music, then just allow noise to import them, and you should be able to play them.

So I am pretty certain that there is no need to reinstall the restricted-extras package, unless of course you didn't install it when you were installing elementary for the first time.


Try importing your music again. If you're importing the same music, a prompt will appear saying that the files are already in the library. Ignore it. Try to play a song. The app should work by then. Unfortunately, you have to do this every time you turn on your computer.


I have had this issue myself. My music data was stored on a seperate HDD within my computer. Every time I power on my computer I have to open the main directory of that drive in the 'Files' application.

  • use GNU disks to set up automount May 5, 2020 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.