0

I still have a problem with the native eOS calendar app. By now, I have figured out that eOS will give me notifications of my events, bubt they appear approx. 2 hours after the start of the event. I even tell the app to specifically give me a notification when the event starts.

I think, that somehow my local time or somewhat related must be off, since that's the only possible reason I can come up with to produce such a weird error.

Now, I have tried to reset the time of my machine (ThinkPad X220) with enter image description here
and set it to automatic, but nothing has changed.

It might be noteworthy thatI disabled all other notifications, except for "calendar" and "other".

I made another post regarding this topic, but I have now found out that the problem lies somewhere else. I ask politely for someone to delete my older post (no notifications from calendar application), since it's not of any use anymore.

EDIT: I have noticed that the events are saved differently in and out of the calendar app, see test and test2 event in notification center and inside the app itself.

enter image description here

0

Type in terminal :

timedatectl list-timezones
sudo timedatectl set-timezone <your_time_zone>

To verify type:

sudo timedatectl
| improve this answer | |
  • Thanks for your help, but it's not quite right,yet. But I have noticed that my timezone (Europe/Belin) is exactly 2 hours ahead of the universal time. Therefore, I have a theory that my calendar app (by accident) synchronizes with the UTC, instead of my local time. Do you have an idea on how to fix that? Thanks in advance P.S. after hitting sudo timedatectl, my Terminal tells me that system clock synchronized: yes; systemd-timesyncd.service active: yes; RTC in local TZ: no (<- might this one be the problem?) – fruitiest Punch Jun 24 at 17:48
  • Hi, I have found a reported bug about this issue: github.com/elementary/calendar/issues/92 – Sysadmin Jun 24 at 20:01
  • Here you can see they made change 7 days ago and seems fixed. github.com/elementary/calendar/pull/515 github.com/elementary/calendar Do you know how to compile and build from the source using meson and ninja? If not, let me know. – Sysadmin Jun 24 at 20:09
0

Type all commands in terminal to compile the calendar from source:

sudo apt install libchamplain-0.12-dev libchamplain-gtk-0.12-dev libclutter-1.0-dev libecal1.2-dev libedataserverui1.2-dev libfolks-dev libgee-0.8-dev libgeocode-glib-dev libgeoclue-2-dev libglib2.0-dev libgranite-dev libgtk-3-dev libical-dev meson valac
cd
cd /Downloads
wget https://github.com/elementary/calendar/archive/master.zip
unzip master.zip
cd calendar-master/
meson build --prefix=/usr
cd build
ninja
sudo ninja install
| improve this answer | |
  • Thanks for the help, but I tried it ad I still have the same issues. All events are delayed by 2 hours, even after compiling from source – fruitiest Punch Jun 25 at 18:18
  • Then the only way is to change the time zone to adjust the time correctly. But this is a really stupid workaround not a solution itself. – Sysadmin Jun 25 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.