For a few months now I've been having this issue where sometimes content from websites are blocked. A few examples are scripts being blocked so I'm unable to log in to certain websites, on Android Studio I have to use an insecure method to download resources (or a system proxy) or it fails, some applications that require a token from online will load up my browser get the token then try to load a local page ( and give the message "connection refused", etc.

I've tested using different browsers, it is not a problem with a specific one, I've tried Firefox, Chrome, Chromium, Midori, and Opera. It's not an ad blocking extension as I've tried all of those browsers out of the box. It is not a problem with a firewall, I have the firewall disabled in the settings. It is not a proxy problem, I am not using a proxy, it is disabled in settings, however if I use Google's data reduction proxy on chrome it solves the issue with non-local content being blocked. It is not an issue with the router as I have no setting specific to my PC and this issue is not present on my other devices, which means it's a software problem on my elementary OS PC. I've also made sure it's not somehow a hardware issue by installing Ubuntu 15.04 and making sure the issue is not present there.

I am running Freya and I have installed quite a few programs and 3rd party PPA's, I've installed nothing specifically having to do with Firewalls, Proxies, etc. Nor have I added any PPA containing such besides possibly a broad PPA such as getdeb.

I have searched for hours on omgubuntu, linux stackexchange, etc. and have found nothing as this is a very specific issue that I cannot find the solution to.

I've also asked this question already on this stackexchange but it was deleted and I was warned that I am now in danger of being blocked. However it is a good question by the standards posted.

I have done hours of research and have not found a case similar to mine. It is on topic as it is a question regarding elementary OS that is a problem I only am experiencing on elementary OS. It is 3 paragraphs which is pretty specific. I tried to make it as relevant to others as possible but it's a very rare issue.

Any input is appreciated and hopefully posting here will help me finally solve this issue that has been plaguing me for months. If you know of a better place for me to ask this question please refer me there.

  • have you tried on another OS to ascertain that it's an elementaryOS specific issue? Commented Oct 13, 2015 at 9:48
  • will you please provide one of those links--and please respond to @TimothyGray question.
    – Ravan
    Commented Oct 13, 2015 at 9:56
  • As I stated in my question I had previously installed Ubuntu 15.04 and verified that the issue was not present. Commented Oct 13, 2015 at 10:41

2 Answers 2


After trying other search engines and learning their syntax I was able to come across someone who had a similar issue on Ubuntu 12.04 and was able to fix it using

sudo dpkg --reconfigure --all

Which had me alter a few things like apache and ssl certs. After a reboot I don't seem to be having the issue anymore. I feel bad that I found the answer so soon after I had posted this question but I'm glad my last attempt to fix it was fruitful.


It might have to do something with your hostfile as all browsers have this issue. You can open your hostfile by opening /etc/hosts.

sudo scratch-text-editor /etc/hosts

It should contain something like this:   localhost   <your pc name>

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.