0

Recently I installed elementaryos Hera to my dell inspiron 5378 which is a 2 in 1 laptop. Whenever I unlock my pc, my pc is in tablet mode in most of the time which disables the keyboard and sometimes auto-rotates the screen.

My question is how can I disable the screen rotation and enable the keyboard for typing my password in login screen.

P.S. I had this problem in gnome (Popos, Ubuntu) but not in KDE (Kubuntu). I think problem will solved if I use sddm but I would like to keep the default login screen if its possible.

What I tried that didn't work: disabling screen rotation from dconf editor

Thank you for your support.

  • In the upper right corner, click on the bar (with wifi and sound and power settings). On the popup, in the lower row, there are four logo's ... click on the second (= tilted rectangle). Now tilting is turned off. But I am not sure will it work and do you have this option. – Sysadmin Jun 16 at 9:12
  • Second option is to type this command in terminal: sudo xinput disable "$(xinput -list | awk -F'[=\t]' '/ELAN/{print $3}')" – Sysadmin Jun 16 at 9:18
  • Thanks I appreciate your help but neither of them work for me. I dont have the options from the first comment you made and second comment just disabled the touchscreen didn't have any affect on keyboard and screen rotation – Aras Jun 16 at 9:40
  • I have found another thread: elementaryos.stackexchange.com/questions/16544/… You can try solutions provided there. – Sysadmin Jun 16 at 13:09
  • thanks hopefully it will work I will give it a try :) – Aras Jun 17 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.