0

I am new to elementary, having installed it today (without clicking the update or install drivers in installation) and I noticed the abysmal internet speeds on my computer. Tested it using fast.com and got 3 Mbps on my phone and 0.3 Mbps on my computer.

I am guessing its some kind of driver error since I did not install any WiFi drivers yet but I also found no guides on this matter (running a built in Intel ® Dual Band Wireless-AC 9260).

So if it is a missing driver, how do I install it? and if not what is the issue?

  • I recommend you to connect the phone to your computer through USB cable, set USB-tethering on your phone in order to shre internet from your phone to your computer without wi-fi(but through the usb cable) and do the same tests. Edit your question with the results - does it change, or again you have a lot more slower internet on your computer? – Bo rislav Jun 15 at 10:36
  • I tried that and it showed good internet, solved it awns: the antenna was folded in, Bluetooth was on and the wireless mouse antenna was placed on a USB port next to the WIFI antennas so they completely handicapped the card. Solved all three and speeds are back to normal. – RetroCausalElectron Jun 15 at 14:05
0

It was a hardware issue:

  • USB antenna was next to the WiFi antennas
  • WiFi antennas themselves were folded in too much
  • Bluetooth was on
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.