1

AppCenter were indicating for months that there was an update for ibus and gir. I never use the AppCenter so I continued to use my bash alias to update the system:

alias upd8="sudo apt update && sudo apt upgrade -y && sudo apt autoremove && sudo apt autoclean"

The command above NEVER installed the aforementioned updates, because there was some unmet depencencies or something like that.

But, one day I clicked in the system updates button in AppCenter and boom.

Now I can't see sound settings (screenshot below). system's settings panel screenshot, but without showing sound settings icon The sound card works, but I can only control its volume.

I checked here and here but no luck as you can see below.

vinicius@vinicius-Aspire-E1-571:~$ sudo apt policy switchboard-plug-gcc-sound
switchboard-plug-gcc-sound:
  Instalado: (nenhum)
  Candidato: 0.2.0-0~77~ubuntu0.4.1
  Tabela de versão:
     0.2.0-0~77~ubuntu0.4.1 500
        500 http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial/main amd64 Packages

vinicius@vinicius-Aspire-E1-571:~$ sudo apt install switchboard-plug-gcc-sound
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:
Os pacotes a seguir têm dependências desencontradas:
 switchboard-plug-gcc-sound : Depende: unity-control-center mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

vinicius@vinicius-Aspire-E1-571:~$ sudo apt install unity-control-center
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 unity-control-center : Depende: ibus
                        Recomenda: ibus (>= 1.5.0)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

vinicius@vinicius-Aspire-E1-571:~$ sudo apt policy ibus
ibus:
  Instalado: (nenhum)
  Candidato: 1.5.11-1ubuntu2.4
  Tabela de versão:
     1.5.11-1ubuntu2.4 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     1.5.11-1ubuntu2.3 0
        100 /var/lib/dpkg/status
     1.5.11-1ubuntu2 500
        500 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

vinicius@vinicius-Aspire-E1-571:~$ sudo apt install ibus
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 ibus : Depende: dconf-cli mas não será instalado
        Depende: gir1.2-gtk-3.0 (>= 3.8.5) mas não será instalado
        Depende: gir1.2-ibus-1.0 (= 1.5.11-1ubuntu2.4) mas não será instalado
        Depende: adwaita-icon-theme mas não será instalado
        Depende: librsvg2-common mas não será instalado
        Depende: python3-gi mas não será instalado
        Depende: dconf-gsettings-backend mas não será instalado ou
                 gsettings-backend
        Depende: libatk1.0-0 (>= 1.12.4) mas não será instalado
        Depende: libdconf1 (>= 0.14.0) mas não será instalado
        Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) mas não será instalado
        Depende: libgtk-3-0 (>= 3.9.10) mas não será instalado
        Depende: libibus-1.0-5 (>= 1.5.11-1ubuntu2.4) mas não será instalado
        Depende: libnotify4 (>= 0.7.0) mas não será instalado
        Depende: libpangocairo-1.0-0 (>= 1.14.0) mas não será instalado
        Quebra: libglib2.0-0 (< 2.48.2-0ubuntu4.5~) mas 2.48.2-0ubuntu4.1+elementary0.4.1 está para ser instalado
        Recomenda: ibus-gtk mas não será instalado ou
                   ibus-qt4 mas não será instalado ou
                   libqt5gui5 mas não será instalado
        Recomenda: ibus-gtk3 mas não será instalado ou
                   ibus-qt4 mas não será instalado ou
                   libqt5gui5 mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Tried this step-by-step to fix broken packages, but console doesn't show any broken packages.

At the end of the day I'm without sound settings, ibus, gir and probably more stuff I didn't miss (yet). And I can't see a way to fix this besides a full backup and OS upgrade :-(

5
  • 1
    Did you try sudo apt install switchboard-plug-sound? – Vlad Jun 12 '20 at 22:18
  • Have you tried force install it? – Storm Jun 13 '20 at 6:52
  • @VladPop apt says this package doesn't exist. The question shows my tentative of installing switchboard-plug-gcc-sound (with -gcc- in the package name), but no luck. – Vinícius Ferraz Jun 13 '20 at 23:14
  • @Storm it didn't work. I says it depends on unity-control-center, which depends on ibus, which depends on something else. I'm feeling I'm going dirty forcing all those unmet dependencies. – Vinícius Ferraz Jun 13 '20 at 23:16
  • It seems that elementaryos.stackexchange.com/questions/23965/… has a possible solution, but I'm quite afraid it will mess with my GIMP dependencies, which I use a lot. – Vinícius Ferraz Jun 29 '20 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.