I installed elementary tweaks and enabled the dark mode toggle but the dark theme isn't applied to system settings app, although it works on other apps like files Using 5.1.5 Hera

4 Answers 4


From eOS Reddit: https://www.reddit.com/r/elementaryos/comments/gxhsi9/slowly_losing_dark_theme_with_each_update/

replace the file at /usr/share/dbus-1/interfaces/io.elementary.pantheon.AccountsService.xml with the contents of


  • Unfortunately, this does not work for me running eOS 5.1.6. Commented Jul 14, 2020 at 8:50
  1. Open terminal
  2. sudo vi /usr/share/dbus-1/interfaces/io.elementary.pantheon.AccountsService.xml
  3. Replace the whole code with https://github.com/elementary/default-settings/blob/master/accountsservice/io.elementary.pantheon.AccountsService.xml, :put+
  4. Change the PrefersColorScheme value from 0 to 1.
  5. Save the changes, :wq
  6. Restart the system, don't just sudo service lightdm restart because it won't work.

Tested on eOS 5.1.6.


I would like to add to MA Jacob's solution that, if you follow his solution but still don't see a dark mode in things like:

  • The system settings
  • The Applications Menu and other wingpanel indicators

It might be because you changed your Plank Theme.

I did this, since I wanted a transparent dock (Ctrl + Click on Dock, Preferences, Theme) and the aforementioned stayed in light mode.

Changing it back to "Default" solved it for me. I still got my transparent dock by copying /usr/share/plank/themes/Transparent/dock.theme to /usr/share/plank/themes/Default/dock.theme (backup the Default/dock.theme first) and leaving the setting on Default to keep dark mode.


the PrefersColorScheme solution worked to me. Thanks! the dark theme turned to light after several system updates. I remember I turned the dark theme on under the system settings panel, now the option it's not there anymore. Anyone knows why? I am running 5.1.7 Hera

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.