0

My super key swapped randomly with the alt key. For example, when I click super key nothing happens, but when I click alt, the shortcuts help pops up.To close a window I need to click super+f4. In keyboard settings, everything is configured correctly.

I've tried to add setxbkmap -option altwin:swap_alt_win to startup, and it works until i change windows with alt+tab. Can anyone help? It is very annoying.

2 Answers 2

2

You can try this

setxkbmap -option altwin:swap_lalt_lwin

See the difference? lalt = left alt, ralt = right alt. The same with lwin and rwin.

To restore default

setxkbmap -option
2
  • It solved my problem but I still wonder why the keys swapped. Thanks! Jun 11, 2020 at 13:12
  • Honestly I do not know. I never experienced such behavior.
    – Sysadmin
    Jun 11, 2020 at 13:16
0

In a multi-mode keyboard, there's a button to swap from Win to Mac layouts (Win/Mac).

  • In Win's, the Super key is to the left of the Alt.
  • In Mac's, the Alt (Option) key is to left of the Super (Command).

These keys are swapped in the design of actual keyboards, so probably you've changed this configuration by accident.


Solution: Look up how to change from one layout to another in the manual of your multi-mode keyboard.

In my case, I was using a RAPOO 8050T and reverted back to Win's by pressing Fn+Ins. Now Super and Alt are mapped to the correct keys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.