0

I'm trying to install and use ulauncher, and I had set Super + Space as the shortcut. But when I press the shortcut, ulauncher doesn't gain focus as in I'm not able to enter anything into the input box unless and until I click on it.

And when I set gsettings set org.gnome.desktop.wm.preferences focus-mode 'sloppy', it still requires me to hover on the input box to start searching for applications.

It would be of great help if someone can help me with this. I basically want to search for apps as soon as I press Super + Space after it opens up ulauncher.

0

Answers from here: https://github.com/Ulauncher/Ulauncher/issues/222

molguin92 commented on Jul 5, 2018 •

Hi! Sorry for necroing this thread, but I found a workaround to this issue.

The problem lies with the /org/gnome/mutter/overlay-key dconf key, which determines the key bound to launch the overview in Gnome Shell and is set to Super_L by default. This is in addition to the default binding of Super+S set in the Keyboard Shortcut settings. Changing this key to something else (I set it to the right Super key, Super_R) allows the use of the left Super key for launching ULauncher. I've done this for some time now without any adverse effects, and I can still access Gnome Shell's overview through the use of Super + S.

@gabrieldrs gabrieldrs commented on Oct 3, 2019

Hey, sorry again for bringing this up, but this is one of the first results on google about this issue and @molguin92 solution is not applicable to Ubuntu 19.04.

In order to change the shortcut now you have to install gnome-tweak-tool. Inside it, go to Keyboard & Mouse and there's an option to change the Overview Shortcut to the Right Super.

This indeed fixes the Super + space shortcut problem with ulauncher in gnome.

| improve this answer | |
  • Okay, but my issue got fixed by increasing the sleep of ulauncher-toggle script (mine is in /usr/bin) to 0.05 – Rajkumar S Jun 13 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.