3

I simply can't create a persistent USB thumb of elementary OS (last version download from the site) using usb-creator from the repos. Is there something wrong with that package? Or it simply does not work with elementary OS?

What is the working alternative?

  • do you want to install elementary OS on usb? – Ravan Oct 12 '15 at 10:25
  • what is your current OS and which usb creator you used?...it sounds like Ubuntu,correct? – Ravan Oct 12 '15 at 10:30
  • Sorry, I am currently on eOS Freya. – lf_araujo Oct 12 '15 at 10:45
  • Just wondering, how did you go with this? I used unetbootin on my Mac, but it seemed to duplicate the MBR (boot USB on a Mac then shows 3 options: Mac, Windows and EFI Boot). Anyway, I was able to edit syslinux.cfg to be persistent using the above info and it worked ok. I even removed the boot menu completely. But I could only have a 4GB persistent drive, I want to use the full 32gb USB stick. – Craig Skipsey Oct 5 '16 at 12:17
  • Hi Craig, right now there is no easy solution for expanding to all the size of the USB stick. The only working solution uses mkusb, see here. – lf_araujo Oct 10 '16 at 0:49
1

You can install Unetbootin from the official repositories.

sudo apt-get install unetbootin

or you could try the command dd which is installed by default (but should be used with extreme coution!)

  • Unfortunately, that does not solve the problem. The system is created, but it is not persistent. Similar to what happens when usb-creator is used. – lf_araujo Oct 12 '15 at 23:56
  • I have the same thing happening on some of my USB sticks. Have you tried another USB stick? – Jeroen Oct 13 '15 at 6:58
  • I actually found a solution, and will post in here in a minute. – lf_araujo Oct 13 '15 at 6:59
1

It seems that usb-creator and unetbootin from Ubuntu 14.04 repos does not play well with UEFI.

The solution is to mount the drive after the process is complete, edit the boot.cfg file under /boot and add persistent to the relevant boot entry at the line:

linux   /casper/vmlinuz  persistent file=/cdrom/preseed/ubuntu.seed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.