0

Yesterday I start work and take my laptop to office. In home I have automount NFS drive. Now in my office I cannot start Pantheon-files - "Window is not Responding..." It works when I run from terminal:

io.elementary.files

Regards Przemek

12
  • It is odd that it works from the commandline but not from the dock (I assume that is how you are trying to start it unsuccessfully). You could use system-monitor or htop to check whether Files is running in a loop and become unresponsive. The NFS mount should not matter. You could try changing the Files setting io.elementary.files.preferences.restore-tabs to see whether it helps. Make sure all existing Files processes are killed. If there is one that has hung it may prevent anymore being started. Jun 8 '20 at 11:01
  • Hi, thank for Your answer. When I try today it won't start from command line either. $ io.elementary.files ** Message: 14:03:16.758: Application.vala:50: Report any issues/bugs you might find to https://github.com/elementary/files/issues [1] 19554 killed io.elementary.files
    – PrzemekS.
    Jun 9 '20 at 12:06
  • $ io.elementary.files.preferences.restore-tabs zsh: command not found: io.elementary.files.preferences.restore-tabs
    – PrzemekS.
    Jun 9 '20 at 12:09
  • To change the io.elementary.files.preferences.restore-tabs setting to "off", use the command gsettings set io.elementary.files.preferences restore-tabs false. Or you could install "DConf Editor" from the appcenter if you prefer to use a GUI. Jun 11 '20 at 14:45
  • The error message from the command line suggests that the Files process was killed by the system rather than crashed. Not obvious why that should be. Could you give more info about the system you are running it on as zsh is not the default elementary shell. Jun 11 '20 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.