0

So I got lucky to hit the only card that doesn't get sound, card is recognized but there's simply no sound and I read that it's related to https://bugzilla.kernel.org/show_bug.cgi?id=55541 what are the steps, if possible, to compile my custom kernel to include that fix ?

I'm also using a Y splitter so speakers + headphones redirect to the same hole.

alsamixer output

0

Edit: It goes without saying (right?) that you should check systemsettings > sound and make sure you're not muted, and have the proper output picked.

There's no reason to compile anything. As of kernel 4.18 or 4.20 (I don't recall which) the Soundblaster Z has been included. It's possible you just need the "linux-firmware" package.

Not knowing what kernel you're currently on, run the following in a terminal:

 sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 linux-firmware

And then reboot once done.

If that doesn't work, open up a terminal and type "alsamixer". If you have other sound cards in your pc, hit F6 and pick the one that says "HDA Creative", and make sure the different outputs aren't muted. Once you're done fiddling around, exit by pressing Esc, and then type "sudo alsactl store", fill in your password.

| improve this answer | |
  • The command didn't install anything since it's already installed, 5.3.0-53-generic #47~18.04.1-Ubuntu SMP Thu May 7 13:10:50 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux for my kernel, adjusting the master volume also sets the speaker bar on my desktop, and the correct sound card + output device is selected, still no sound though ? – adaba Jun 2 at 9:05
  • The command included the linux-firmware package as well. Was that also installed? Did you check in alsamixer? – user20763 Jun 2 at 11:50
  • Make sure to disable HP/Speaker Auto Detect and set Output Select to surround.in alsamixer. Nothing you change in Alsamixer will "destroy" anything, so just poke around with all the settings, while having some music playing. – user20763 Jun 2 at 11:55
  • yes, I mean all the packages in your command were already installed, tried fiddling with alsamixer putting everything to maximum and playing with M to mute unmute, also toggling "HP/speaker auto detect" makes a pop noise I updated the post with a picture but still no sound :( – adaba Jun 3 at 16:45
  • That's an interesting one, then. I currently have the ZxR that works fine. albeit a few issues with surround. I'm not sure how to help further. The support for these cards were made by a single guy here: reddit.com/r/SoundBlasterOfficial/comments/9mm5ad/… what you could do is contact him, and see if he has any ideas. Otherwise you should report it as a bug to the kernel developers. – user20763 Jun 3 at 17:06
0

I have no idea are you using the 32 -bit architecture and Elementary OS as far as I know is 64 bit, so reading this comment from the website you mentioned is crucial:

mmstick 2014-01-10 05:20:49 UTC The problem has been known since 2011 pretty much. There's no fix that I have found other than using 32-bit or buying something else, like an external USB DAC or a supported ASUS card. When you do get it to work in 32-bit, you can't use the equalizer unless you manually patch the patch_ca0132.c file yourself. I have no idea why the issue with 64-bit hasn't been fixed yet, nor why the equalizer is not enabled by default.mmstick 2014-01-10 05:20:49 UTC The problem has been known since 2011 pretty much. There's no fix that I have found other than using 32-bit or buying something else, like an external USB DAC or a supported ASUS card. When you do get it to work in 32-bit, you can't use the equalizer unless you manually patch the patch_ca0132.c file yourself. I have no idea why the issue with 64-bit hasn't been fixed yet, nor why the equalizer is not enabled by default.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.