Today I bought a cheap usb bluetooth adapter to use it with my bluetooth headphones, and I've tried to connect them and use them. When I try to connect them it either says Unable to connect or asks me for a pin (Which it shouldn't do) and no matter what I put on the input, it says connected just to get disconnected after 5 minutes, and in these 5 minutes the headphones don't appear in the sound settings. So it's either not connecting or I'm missing something :(

I'm using elementary OS 5.1.4 Hera with Linux 4.15.0-101-generic

I've tried several fixes and I'm truly using this as my last resort Thanks in advance for any help :)


3 Answers 3


It is a possibility the bluetooth adapter just isn't supported in your current kernel. I'd recommend upgrading with the ubuntu HWE, and then making sure the "linux-firmware" package is installed.

Run the following in a terminal:

 sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 linux-firmware

Then reboot and test if it works.

  • It seems like the problem has... Evolved? Now it maintains connected if I'm in the bluetooth window, but disconnects as soon as I close it, and the sound still does not come from the headphones
    – Codedgar
    Commented Jun 3, 2020 at 17:45
  • Can you tell me what the bluetooth adapter is called, and what headset it is as well? It could also just be bluetooth system being bugged. Have you tried connecting other bluetooth devices, maybe a phone?
    – user20763
    Commented Jun 4, 2020 at 10:48
  • I tried connnecting the Xiaomi redmi headphones, JBL headphones and Beats. I also changed the bluetooth dongle (The seller tried it and said that it worked for him ini Windows 7). Running lsusb from the terminal returns "Bus 002 Device 006: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)"
    – Codedgar
    Commented Jun 4, 2020 at 21:04
  • A few google searches tells me this dongle is rather problematic. You can look here: askubuntu.com/questions/1208296/… and see if any of the answers are helpful. :)
    – user20763
    Commented Jun 5, 2020 at 9:05
  • 1
    Hecc :'( Now I have another problem, the beats connected, buuut now the audio from the laptop sometimes work and sometimes doesn't. I paid 3$ for this dongle but it feels like I paid with my soul lol
    – Codedgar
    Commented Jun 6, 2020 at 4:59

Hi I had a similar problem. (The Device showing connected but not appearing in the sound settings and then disconnecting(additional problem))

I referred to this answer and the solution sudo apt-get install blueman worked for me. Figured out that it might help you out.

Note to Mods: This is not an answer but I don't have enough reps to comment, hence you may add it as comment and remove it.


On Elementary OS Hera 5.1.7 (based on 18.04.4) using kernel 5.8.0-39 (necessary for hardware compatibility reasons), I was able to resolve this issue by

  1. installing pavucontrol and blueman and
  2. editing /etc/bluetooth/main.conf "MultiProfile=multiple" under "general" (see https://wiki.archlinux.org/index.php/Bluetooth_headset#A2DP_not_working_with_PulseAudio) change "AutoEnable=false" (not sure if that did anything)

Before this, I couldn't connect to bluetooth audio sinks, period, unless I used bluetoothctl. At that point, it would only connect to the duplex low quality sink (HSP/HFP) and not A2DP (high audio quality).

Now it appears to be able to work well enough in either mode, with mode-switching on the fly, however, with consistent errors:

[  994.225669] Bluetooth: hci0: urb 0000000085e83e50 submission failed (90)
[  994.225675] Bluetooth: hci0: sending frame failed (-90)
[  994.238145] Bluetooth: hci0: SCO packet for unknown connection handle 0
[  994.238153] Bluetooth: hci0: SCO packet for unknown connection handle 0
[  994.238155] Bluetooth: hci0: SCO packet for unknown connection handle 0
[  994.238157] Bluetooth: hci0: SCO packet for unknown connection handle 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.