0

Edit : For clarification, the issue is EOS not shutting down (both restart and shut down stay hanging with a black screen and no possible interaction). Following is the original question with the hardware details :

I have EOS installed on a huawei matebook D (Ryzen 2500U CPU, no graphics card), the OS is up to date. I have noticed the battery drains to zero in a day or so when the laptop is not in use. This doesn't happen with Windows or Solus. This is probably damaging the battery and I hope somebody has a solution.

The battery life is actually ok when in use since I installed tlp with the default configuration (the displayed battery life is 9 hours when in light usage, same as Windows 10). Has anyone encountered something similar and come up with a solution?

Edit : I suspect this is because elementary doesn't shut down properly on my computer most of the time, the screen is black but still lit and the computer is unresponsive and must be shut down with the power button. Edit2 : I added the "nomodeset" to the grub options and shutdown/reboot works fine now. However I can't resume from hibernation anymore : I get a black screen and I can't even open a tty session.

  • So the problem is that your laptop doesn't shut down. Have you tried disabling usb autosuspend on shutdown? There's a setting for that inside TLP. There may be a device preventing your computer from shutting down. – Maccer May 30 at 11:43
  • Yes and there is no device connected. I also tried disabling tlp entirely. Should I close this question and open another one for EOS not shutting down ? – kouign-amman Jun 1 at 12:21
  • (1) I advise to edit questions instead of creating another one. And regarding the usb devices, please bear in mind that some things that are integrated into your laptop may use a USB port (like the webcam or the bluetooth/wifi module). Just to be clear, have you set the following inside TLP: USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1 and restarted TLP with sudo tlp bat ? – Maccer Jun 2 at 17:01
  • (2) Regarding NOMODESET. It's only a kernel parameter that you'd want to use as a temporary fix. Can you check Appcenter and install the drivers that appear on the installed tab? – Maccer Jun 2 at 17:02
  • No I twas using the USB_AUTOSUSPEND option, thanks for the clarification. I tried USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1 (after removing nomodeset from the grub file) and it doesn't solve the issue. I also downloaded the driver (backport-iwlwifi-dkms) and it didn't change anything. – kouign-amman Jun 2 at 19:10
0

Solved : I have a dual boot installation with Windows 10 and somehow several updates waiting for installation were causing this issue. After installing them and removing the grub files modifications everything works fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.