0

I have an Asus Zenbook Flip S. I have been using it with Zorin OS for a while, until I discovered a bug which made the laptop unusable. Namely, the internal mic does not work, at all.
I installed Windows, and after changing some setting the mic worked flawlessly, so I know it is not a hardware issue. I then tried booting live usbs of a bunch of distros, but none of the live sessions could use the mic, until elemantary OS 5.1. In the live session the mic just worked, with no needing to muck about with any settings at all, so I installed eOS. Imagine my frustration when after installation, the mic was again not working at all.

Symptoms:
When I go into sound settings and click input, sometimes the input level shows input for an instant but immediately drops to nothing. Other times it just shows nothing with shwoing for that instant.
The mic naturally does not work. (tested by recording in whatsapp web and using an online mic checker, as well as seeing no bars in the settings screen.)
There are 2 input devices, even when the computer is not connected to anything at all. One is listed as "Internal Microphone - Built in audio" and the other is listed as "Headset Microphone - Built in audio". When I connect a bluetooth headset, a third option appears, "Bluetooth headset", and this works perfectly.
Regardless of which setting I pick, what volume it is at, and ensuring it is not muted, nothing gives me mic.

STEPS I HAVE TAKEN:
I have tried installing pavucontrol, but no setting I tried there has any effect. Same with gnome-alsamixer.
I don't really know what I'm doing in alsamixer, gnome-alsamixer, or pavucontrol, but I followed multiple suggestions from multiple questions on the web, but nothing has helped.

SCREENSHOTS:
What I see when I enter settings: What I see when I enter settings

pavucontrol:

enter image description here enter image description here

gnome-alsamixer (Default:)
enter image description here

Settings aftter unmuting and raising volume in gnome-alsamixer:
enter image description here

lasts for an instant and then drops to this:
enter image description here

While the state is as shown in the last screenshot, the mic does not work.
After switching between the two built in audio options, the "headphone" slider in gnome-alsamixer mutes itself again. This is the exact same behavior as I had in Zorin.
I am truly at my wits' end here, I will not use Windows but I can't keep using a laptop with no mic. Thanks.

0

After isolating the issue of it working under live usb, I finally realized that it must be the kernel. I installed an old 4.19 kernel and booted into that, and it works perfectly now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.