Here are the key details:

  • Dell Latitude E6530
  • NVIDIA NVS 5200m with Optimus
  • Hera 5.1.4

What is happening: My keyboard and mouse stop working when the desktop loads. I can use the input devices in the BIOS and in the recovery terminal. Prior to this issue, the laptop worked perfectly. I could play Steam games, browse the web, use the terminal, etc.

When it started: I updated my driver to nvidia’s 435 driver, and in the next reboot my keyboard, trackpad, USB mouse and USB keyboard are entirely unresponsive.

What I’ve tried:

  • Purging and reinstalling the old driver
  • Switching the selected graphics card in nvidia-settings
  • Quietly sneaking up on my laptop while wearing a wig and fake mustache and quickly booting it before it recognizes me

Any suggestions as to what is going on, and how I can fix it?

2 Answers 2


Ok, so I get to answer my own question. This is not an elementary OS issue, but rather a general Linux thing. Apparently, X likes to break inputs on upgrade.

To fix this, I just rebooted into recovery mode, enabled networking and dropped into root and ran apt-get install xserver-xorg-input-all

Just like that, I'm back in business.

Original solution


Could you check in your BIOS, if you have the option to set the graphics card mode? There should be something like discrete and hybrid mode, if available.

This should be set to hybrid mode.

  • Optimus is enabled in the BIOS, which I believe is nvidia’s hybrid mode. It was working previously, before I got cute and upgraded the driver. Commented May 18, 2020 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.