1

I know that many people asked this question. But I can't simply install WINE on my laptop

here is one of many guides I followed: LINK

basically I'm getting errors after typing the following command: sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'

error:

Hit:1 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease
Hit:2 http://am.archive.ubuntu.com/ubuntu bionic InRelease                                                                                                  
Hit:3 http://am.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                          
Hit:4 http://am.archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                                        
Get:5 http://packages.elementary.io/appcenter bionic InRelease [5,909 B]                                                                                    
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease                                                                                           
Hit:7 http://ppa.launchpad.net/cybermax-dexter/sdl2-backport/ubuntu bionic InRelease                                                                        
Hit:8 https://dl.winehq.org/wine-builds/ubuntu focal InRelease                                                                                              
Hit:9 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic InRelease                                                                                 
Hit:10 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu bionic InRelease                                                                            
Hit:11 https://packages.microsoft.com/ubuntu/18.04/mssql-server-2019 bionic InRelease                                                                       
Hit:12 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic InRelease                                                     
Hit:13 http://deb.playonlinux.com bionic InRelease                                                                                         
Hit:14 https://packages.lunarg.com/vulkan/1.2.131 bionic InRelease                                                                              
Ign:15 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic InRelease                                                                         
Hit:16 https://packages.microsoft.com/ubuntu/19.10/prod eoan InRelease                                                    
Err:17 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic Release                                                                           
  404  Not Found [IP: 91.189.95.83 80]
Hit:18 https://dl.winehq.org/wine-builds/ubuntu eoan InRelease                                                                                  
Hit:19 https://packages.microsoft.com/ubuntu/18.04/prod bionic InRelease                       
Get:20 http://packages.elementary.io/appcenter bionic/main amd64 DEP-11 Metadata [240 kB]
Hit:21 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                            
Reading package lists... Done 
N: Ignoring file 'winehq.key' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ubuntu-wine-ubuntu-ppa-bionic.list.backup' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: The repository 'http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I thought maybe ignoring the error will fix my problem :) but it didn't (who would have thought)

output of sudo apt install --install-recommends winehq-stable

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.0~eoan)
N: Ignoring file 'winehq.key' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ubuntu-wine-ubuntu-ppa-bionic.list.backup' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to correct problems, you have held broken packages.
1

First, the files winehq.key and ubuntu-wine-ubuntu-ppa-bionic.list.backup have no place in /etc/apt/sources.list.d/. The .key files can be safely deleted after adding them. Read more about the apt folders here.

Second, the instructions on the winehq site are incomplete as they themselves admit it: enter image description here
So, use the instructions from here to add a new repository containing the required packages, and hope for the best :D.

EDIT:

  • please remove the http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu repository, it contains nothing useful since xenial and I think it is no longer maintained (Err:17 in your post)
  • there should be no eoan anywhere in your sources list, so comment or remove the https://dl.winehq.org/wine-builds/ubuntu eoan from your sources.list file (should also solve the Depends: wine-stable (= 5.0.0~eoan) error)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.