1

upper tray icons I was wondering if there was any way to bring the upper tray icons more closer so that they look appealing. Please help me out.

0

Ayatana indicators for apps , tlp, tlp UI , slimbook battery - works on DELL not only Slimbooks. It should work on all laptops.

Copy all bolded text below:

mkdir -p ~/.config/autostart && cp /etc/xdg/autostart/indicator-application.desktop ~/.config/autostart/ && sed -i 's/^OnlyShowIn.*/OnlyShowIn=Unity;GNOME;Pantheon;/' ~/.config/autostart/indicator-application.desktop && wget http://ppa.launchpad.net/elementary-os/stable/ubuntu/pool/main/w/wingpanel-indicator-ayatana/wingpanel-indicator-ayatana_2.0.3+r27+pkg17~ubuntu0.4.1.1_amd64.deb && sudo dpkg -i wingpanel-indicator-ayatana_2.0.3+r27+pkg17~ubuntu0.4.1.1_amd64.deb && systemctl reboot

then type in terminal

cd /home/yourusername


sudo vi indicators.sh

press ins button to go into insert mode

press ctrl+shift+v to paste

press esc button to escape insert mode

type

:wq

this will write and quit the file

then type

sudo chmod +x indicators.sh

then type

./indicators.sh

script will run, install ayatana and restart the machine

Works in hera 5.1

For double wi-fi icon

mv /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart/nm-applet.desktop.old

Additional gift for battery saver. Requires tlp to work

sudo apt update



sudo apt install tlp



sudo add-apt-repository ppa:slimbook/slimbook



sudo apt update



sudo apt install slimbookbattery



sudo apt install gnome-shell-extension-appindicator

If you need also tlp UI

then type in terminal:

sudo add-apt-repository ppa:linuxuprising/apps



sudo apt install tlpui

to remove slimbook battery and app indicator

sudo apt remove --autoremove slimbookbattery gnome-shell-extension-appindicator

to remove tlp

sudo apt remove --autoremove tlp

to remove tlp UI:

sudo apt remove --autoremove tlpui

How to remove gaps between icons in wing panel a tutorial

1 - Install the wingpanel indicator mentioned in previous post

2 - Download libayatana_compatibility.so.zip from here: libayatana_compatibility.so.zip and unzip it

Open terminal and go to Downloads

cd /home/username/Downloads

unzip libayatana_compatibility.so.zip

3 - Go To (with sudo) /usr/lib/x86_64-linux-gnu/wingpanel/

sudo -i

Type your sudo user password

cd /usr/lib/x86_64-linux-gnu/wingpanel/

4 - Backup your libayatana_compatibility.so

mv libayatana_compatibility.so libayatana_compatibility.backup

5 - Replace the libayatana_compatibility.so with the zipped one

cp /home/username/Downloads/libayatana-compatibility.so /usr/lib/x86_64-linux-gnu/wingpanel/

6 - reboot

systemctl reboot

source

https://github.com/mdh34/elementary-indicators/issues/1

this works to me with no problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.