0

I am running eOS 5.1.3 Hera and have an Intel UHD Graphics 620 (rev 07) card in my machine. I am looking to make sure that I am updated to the latest drivers before messing with any Wine applications. I was searching for the best way to go about installing these drivers but only found very old articles and pages, which I imagine are outdated by now.

This was the latest link that I attempted to follow: http://ubuntuhandbook.org/index.php/2019/01/install-mesa-18-2-8-ppa-ubuntu-18-04-18-10/

However, the first command listed for the terminal does not execute: add-apt-repository as it is not recognized, and looking at intel's website I don't think Mesa is the newest driver anyhow.

Anyone more knowledgeable than I know how to properly see if I am updated / how to update these drivers in 2020?

0

First thing first. Backup your important files before venturing further.

To add a PPA to eOS you need to install:

sudo apt install software-properties-common

Next thing is to add a PPA which contains driver for intel:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update

Now getting the latest intel driver:

sudo apt install xserver-xorg-video-intel
| improve this answer | |
  • Resulted in this error message from terminal from 4th command: Some packages [not] installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: xserver-xorg-video-intel : Depends: xorg-video-abi-23 Depends: xserver-xorg-core (>= 2:1.18.99.901) E: Unable to correct problems, you have held broken packages. – Mute May 8 at 7:45
  • Just reading through the PPA, it is recommended to update the kernel as well. NOTE: Make sure you have backed up your important files. Command: sudo apt install --install-recommends linux-generic-hwe-18.04 – Storm May 8 at 7:49
  • If it still complain about broken package run: sudo dpkg –configure -a – Storm May 8 at 7:51
  • Hmm, yeah, still complaining about broken packages even after attempting the dpkg. Went through and updated everything from App Store as well as running the generic hwe install. – Mute May 8 at 8:11
  • sudo apt-get update –fix-missing then sudo dpkg –configure -a sudo apt-get install -f – Storm May 8 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.